[1.1.9.3] Don't have correct database version. Issues with multiplayer

Hello there, tried playing with someone today and we encountered some issues getting it to work. Here’s some details along with what we tried so far.

  • We both have the game on GOG, updated to 1.1.9.2.
  • We have AoM and FG, I have Crucible, she doesn’t.
  • I had Grimarillion installed, but I created a vanilla character.
  • I’ve played for a long time, she’s a more recent install.

What we did:

  1. First issue we encountered was launching the game. No issues on my end. She got a black screen when launching via the Play button on GOG.
  2. She tried disabling UPnP, deleting option.txt, running Repair.exe. Still black screen.
  3. She launched the game via the “Launch Grim Dawn” shortcut in the game folder. Game launched, but no connection to GOG, so no multiplayer access.
  4. We give up troubleshooting launching via GOG. We install Radmin VPN, and attempt to connect via LAN.
  5. Game appears in game list. She tries to join but gets “You do not have the correct database version to connect to this server.”
  6. We double check we both have 1.1.9.2, running x64, AoM and FG installed. I uninstall Crucible to be safe.
  7. We test hosting and joining in both directions. Still same error.
  8. We explicitly re-enable UPnP in option.txt. Same error.

At this point we gave up for the day. For now, I’ve uninstalled everything and deleted everything relating to user configs and saves (backed up tho), then reinstalled the game. We’re going to try again tomorrow, but would really appreciate some additional insight on what could be the issue.

Thanks for your consideration and for making such an amazing game!

Are you both launching the game via Galaxy? That’s the only way to multiplay on GOG.

Also some suggestions in here re multiplayer problems.

She was having issues launching via Galaxy, as it presented a black screen issue. Launching from the shortcut mentioned actually started the game, so we decided to try LAN instead, and then encountered the remaining issues.

The game is being detected, but says we don’t have the correct database upon trying to join.



  • I just tested it and it launches via Galaxy and I had access to the Galaxy Overlay etc.

Sounds like you tried a clean instal, did she?

I’d use GOG’s full v1.1.9.2 installation rather than their patcher, just in case.

No need to launch through Galaxy. It is sufficient if Galaxy runs in background when you execute “x64\Grim Dawn.exe” from installation directory.
And no, you can’t use their offline patch if you have any expansions. But updating through Galaxy should work fine.

My friend and I are having the same issue here, completely lost on what it’s caused by. Our setup is a little different though, I have the game on Steam, he’s on GOG. Just like OP, we can see each other’s lobbies just fine, but we get this “You do not have the correct database version to connect to this server” error upon trying to join. Both running x64 versions, with all the DLCs. Would really appreciate some help on how to troubleshoot this.

Welcome to the forum. :slightly_smiling_face:

See if anything here helps

Thanks, I forgot to mention, we’ve already tried the things mentioned there, but none of it seems to help.

Could it be that the Steam version has updated to 1.1.9.3 as a hotfix went out a little while ago. It doesn’t seem to have reached GOG yet.

We both were on 1.1.9.2 when we tried it yesterday, so that’s not it unfortunately.

Update, we both tried a fresh install of the game via Galaxy. We both have 1.1.9.2, but we’re still getting the error saying we don’t have the correct database version.

Try updating to 1.1.9.3.

Hi there. Thanks for walking me through this issue so far, and sorry for the slow updates.

Anyway, we tried updating to 1.1.9.3 now, but we’re still having the same database version issue.

I’ve also tried with port forwarding, but it seems she has shared internet, so can’t tinker with router settings on her end. That said, I’ve been reading the guide you linked above more closely, and it seems port issues prevent the game from appearing on the game list at all. We can probably rule this out as a possible cause, since we do see each other’s game, we just get that error upon trying to join.

Again, thanks for the help so far.

Maybe try this instead of installing via Galaxy.

Then do the 1.1.9.3. hotfix patch.

We tried again today, and a clean install of 1.1.9.3 has fixed the issue. Seems like the patcher was causing it indeed.

Cheers!

Great news! Enjoy!

Dang it! I read this response and was getting hopeful hah.

  1. We tried a clean install, this time using the GOG standalone installers.
  2. We connected using Radmin VPN.
  3. Opened the game using the “Launch Grim Dawn” shortcut in the installation folder and I hosted a game on LAN.
  4. She tried joining, get the database version error again.
  5. I realize this shortcut actually connected with Galaxy. We turn off Radmin VPN.
  6. I try hosting via Internet.
  7. Running the shortcut connects me to Galaxy, but it doesn’t connect her. We double checked, Galaxy is running and we’re both logged on.

Update: Trying to launch via Galaxy still gives her a black screen. Don’t know if this might be related to connection issues. The shortcut on the game folder doesn’t connect for her, while it does for me, and I’m also able to run it from Galaxy.

Have you tried not using the shortcut? Launch it direct from Galaxy?

@medea_fleecestealer

Lemme know if you got a moment free here soon. I figured we could give it a go and check how it turns out for us. Dont think i ever tried my GoG install with multi honestly, just Steam a handful of times.