Bug or Feature?

This is my first playthrough, I am playing a Necromancer (always loved summoners), and have been using this thing the Warden dropped in Act 1 which gives +1 to skelly limit, that gives me 9 in total with my set of skills. Fine.
I just found a knife that gives +1 to all Necromancer skills. When I replace that mace with the new knife, I still have 9 skellies. But my limit is 8 (the mouse-over on the skill window confirms this). Is this a bug or an intended feature?

(Only semi-related question without starting new thread: just specced into Reap Spirit, wheee, but notice there doesn’t seem to be any on-screen indication of the Spirits I have summoned through that skill, e.g. their health or their quantity – I think I have some up, but see no little icon indicating thus; is that right?)

Have you re-summoned all your skellys since swapping to the knife? As might be the +1 skelly hanging about until it’s dead…:undecided:

As for the Wraith from Reap Spirit, there’s no health indicator for these, you just have to keep an eye on them…and you get a 2nd Wraith up once you go over the normal limit of points in the skill. Otherwise as the skill states “One Wraith max”

Hope this helps :slight_smile:

Has undead legion got anything to do with it , you had +1 skelly skill , swapping to +1 necromancers puts a point in undead legion , that affects your skelly limit .
So you can summon 8 with the skelly skill but undead legion adds more , but the skelly skill stays at 8 for that particular skill , thats how I see it could be :slight_smile:

Thanks much! If I recast skellies, the number I have goes back down to 8.

Sorry, where does it say that? I don’t see a spirit # limit anywhere in the description or the mouse-over on my bar :frowning:

Glad the skellys worked. The limit is shown as in the image. If you don’t see this I’ll remove some points and check it still shows.

This is extremely helpful, thank you.
Sadly, I do not see what you see. I have 3 points in Reap Spirit currently, and there is nothing visible on my mouseover, anywhere, about a summon limit. I can’T figure out where to get my screenshot (sorry).

What am I missing?

Strange, the summon limit is showing up for me at level 3 for Reap Spirit:

Are you on version or

strange! I think I am playing
I cannot see this in-game, but this is what the gog.com website is showing as the current version, which I DLed a couple of weeks ago from its site. I realize a new patch is out, but gog doesn’t seem to offer it (yet). In any case, I am not seeing what you are seeing :frowning:

Might be because of the new update then perhaps? I am on as I am on Steam. I might be wrong though as I think Jaknet is also on GOG.

Nope I’m on steam not GoG, I’d update your version to the latest…if gog has it yet…The problem with GoG is they manually check everything before releasing the same update that Steam has had for a few days.

Thanks much.
IIUC I noticed this before was released, and thus I am curious if you people also experienced this a few days ago.
Is it true that if I purchased this via GOG then I cannot benefit from the steam update? (I mean I do have steam installed, but purchased through GOG.) I have to wait, no?

Yes I’m afraid you’ll have to wait for GoG to release it, I’m surprised it’s not out yet, have you tried to get gog to update GD?

GOG is merely a website from which you can download, it’s not a software tool. On its website it still only offers While it does offer one much like steam, I did not choose to install it (try to avoid extraneous auto-start stuff on my computer).

I keep forgetting that GoG and GoG Galaxy are semi separate things. Then unfortunately you’ll have to wait until GoG manually find the time to check the updates before releasing them on their site and via GoG Galaxy. :frowning: