Characters do not show up anymore

So i tried everything i could find about this topic online already and i still can’t get it to work.
My character save games just don’t show up in the main menu even though their saves are under 219990\remote\save\main…
Cloud saving is disabled. When i try to create a new character, their new folder appears together with my old ones.
ANYONE got another idea?
Also my old characters and their inventory show up in Grim Dawn Stash if this helps somehow and i have a seperate backup of them.
Deleting the current folder and replacing it with the backup also didn’t work.

Is cloud saving turned off in both Steam and ingame Options?

Yes disabled that too

Then try turning them both back on.

Already tried that, i just figured out that i can edit a new character via Grim Dawn Stash to resemble my old one and since my old stash savegames work for some reason i think i will just do that. Maybe my old character save file is just corrupted or maybe it will work again tomorrow like i read in another post, still thanks for trying to help!

I’d suggest moving over to local saving anyway. Cloud can mess with things.