Editing Attach Points in Viewer

For now it I guess it shows what to expect during this portion of model adjustments unless the devs actually release a more direct approach in their import/export process.

I’m loading the Yeti mesh (path: creatures/enemies/yeti) named yeti01a.msh in the Viewer and I created this path in source folder (creatures/enemies/yeti/) and I’m able to save it but the file is called Yeti.mif in the source/creatures/enemies/yeti/ folder and when I reload the mesh in the Viewer, none of the attachments display green.

Am I missing a step?
Clearly I am doing something wrong, doesn’t seem too complicated.

EDIT: Just tried to use the file you mention in your tutorial (a player head) and I get the file created (.mif) in the appropriate directory but again it’s blank and reloading the mesh (relaunching the Viewer aswell) and/or saving the MIF doesn’t allow me to move the attachment and create a full (not blank) MIF file.

Okay, so I’m kinda disappointed.

I woke up really early expecting someone to have answered me back so I can start working on my animation and noone responded.
I understand not everyone is familiar with these tools so it might be why the response are slow.

So since I had a lot of time…
I did some more research on the Titan Quest and found out that you actually need to convert the mesh file into .cvs with an external tool.
“Mesh2CSV - This program will take a .msh file and convert it to a human readable .csv file. It can also optionally create a .tga file of the 2D texture mapping points. This can be overlayed onto an actual texture in order to visualize the actual triangles used in game.”

The program is called Mesh2CSV and there’s also instruction on how to use the program.
“The usage is as follows:
Mesh2CSV input.msh output.csv
Will read “input.msh” and create “output.csv”.”

The problem is that I can’t find this tool anymore on the web…
Every links are down.

But let’s say I can find this tool somewhere, then where would I enter the command line? Windows command promt?

Also, I’m trying to understand how come this wasn’t mentioned in this guide.
Unless I was doing something wrong like I previously said, but I did follow these instructions to the letter.

From what I learned (not actually learning anything when I can’t get anything done) you have to convert the meshes into a .cvs file, open that in a text editor and copy the code inside the created blank .mif corresponding to the mesh file you are trying to edit.

I also downloaded the MeshView from Tamschi but I can’t get the meshes to load in it.
Do I need to copy the program into a specific folder or create a folder so it can read Grim Dawn files?
I couldn’t find any “clear” instruction.

Please someone help me :frowning:
I’m losing my head with this nonsense.

I believe the the devs had to change the way meshes work from Titan Quest to Grim Dawn

I think it was part of the deal of them buying the game engine

so that tool wouldn’t work anyway (I think)

hey jamesL, thanks for the respone!

Have you been able to create a .mif file with information on the mesh file in it?
When I load the Viewer after saving the mif, the attachment points are still red. I’m able to create new one and save them into the mif but I can’t edit the current ones.

I wonder if the OP didn’t just copy paste instruction from TQ and adapted them without testing them. Maybe he also forget to copy a very important and crucial step!

We’ll see, most modders are not as early as I am :slight_smile:

Lux can probably provide a few information.
I’ll try to contact him/her.

I found it :smiley:

After saving the mif file, I opened the mesh file of the Yeti with Notepad++.
I had already tried that last night but it display weird characters…

OH GOD! :rolleyes:

Scrolled down the text and on row 4327 I found what I was looking for!
The code with all the attach points, bones and rigid bodies… etc etc…

Copied all the code into the mif file, reloaded the mesh file in the Viewer.
:slight_smile: Now I can edit the Attach Point! Yeah! :slight_smile:

Aw man!..sorry i didn’t get to you sooner.

Just so that there’s no confusion…The main thing that allows you to edit attach points in the Viewer is to have the blank .mif file saved in the correct folder directory. Sometimes the .mif file output name doesn’t match the actual mesh name…(otherwise you would be able to simply manually create a blank .txt file and change the extension to a .mif file.)

Resaving the .mif after the points are green in the Viewer saves the data that is edited (or even unedited). No additional program is needed up to this point. To examine and copy/paste the data into a .msh is when Notepad++ and a functional .msh editor comes in.

Glad you made it up to the same roadblock the guide leads up to though!

I’ll edit the original post to reflect this recent message.

Not sure what you mean when you say “Sometimes the .mif file output name doesn’t match the actual mesh name…otherwise you would be able to simply manually create a blank .txt file and rename the extension to a .mif file.”

I did create the path to save the mif file and it created a yeti.mif blank file.
I tried to name it the save as the mesh file and it didn’t do nothing.
So I followed your example and same thing happened with your example… so you’re saying your provided a faulty example in the tutorial?
That’s kinda evil… :smiley:

Anyway, I still don’t get what you meant by that… because after copying the code from the mesh to the mif file called “yeti.mif”, the one that was auto-generated, I was able to edit the attachment correctly.
So it was indeed the right output name.

But it’s alright.
I am not mad… I know how to do it now at least. :wink:

Oh yeah, I know we can’t create or edit the mesh because we can’t save them but what about a modified .anm file?

Do you know where I would need to copy the file in my mod folder?

I tried the source folder and Auto-Generate Asset on it but it was not a valid file format for asset.
I noticed there’s a folder named ‘resources’ in my mod folder, just like the one in the game folder so I’m guessing I need to copy my file there but how do I build it into my mod?
Can’t find ‘resources’ in the AssetManager so I’m guessing I need to use another tool.
The information is probably somewhere on the Titan Quest forum… sigh

If you know something please share with me :confused:

Okay, I think I need to add the new .anm to Creatures.arc so I can use them in-game.
I think you do this with the ArchiveTool but when I launch it, it will instantly close.
So my guess is that it’s a command line program… (yeah! fake cheers)

I opened the file in Notepad++ (always notepad++ when in doubt) and in the last lines of code I found these commands below.

        -add <directory> <base> [compression (0-9)]: add a file/directory
        -replace <directory> <base> [compression (0-9)]: replace a file/directory
        -update <directory> <base> [compression (0-9)]: update a file/directory
        -remove <file> : remove a file from the archive
        -extract <location> [file] : extract files
        -database <location> [file] : extract database files
        -compact : compact the archive removing unused files
        -removeMissing <file> <base> : remove files not in the specified directory
        -list : list the files in the archive
        -stats : display the archive statistics
        -totalStats -database   Failed to open archive file %s.
    Failed to open archive file %s.
    -add    -replace    -update -replace    -update -remove -extract    -database   (%u/%u) Extracting %s
  -removeMissing  -compact    -list   -stats  Unknown command %s.

This provide me with a few information on how to use the tool but I still don’t know how to do it for a mod instead editing the base file.

For example, the file I used in the guide was: “hero_00.msh” …but the .mif that is generated by the Viewer actually ends up named: “hero_00_body.msh” becuase of the header in the mesh’s .mif data.

Not sure what went wrong there on your end as it has been explained correctly…
You never want to rename the .mif or else the Viewer won’t relate it to the specific mesh. That’s the whole point of the Viewer generating it instead of making one from scratch so you get the correct file name.

I believe it was Rhis that stated they were looking into a .msh import/export tool for the next v1.0.0.4 patch. This would be sweet because once you wrap your mind around attachments, there are so many obscure uses for it. :smiley:

Yeah, saw that post too :slight_smile:

I can’t wait for it, gonna create a head movement in the animation so the Breath looks better (sweeping motion).
If I can get to figure out how the ArchiveTool work…
I read something that I am going to try (probably tomorrow, just felt asleep lying in my bed and feel so dizzy right now).
Apparently, If I copy the new animations to the resources folder of Grim Dawn (if you are using Default path in the AssetManager) and build the archive in your mod, you will “save” your changes and the AssetManager will build a new ARC file containing the animations (or whatever you added to that folder).

I still need to figure out if this is the correct way to do it.

For now, I’m just gonna move back to creating skill and playing with the DBREditor.
This whole meshes, animations things can give you a terrible headache!

The engine should at least accept a replaced .anm with the same name because it worked for a .msh that i had messed up.
It was that hero_00.msh
In game I had the player mesh running out of the camera view any time I tried to move…then it would snap back into view as soon as I tried to move again.:rolleyes:

Thanks for the response :stuck_out_tongue:

I’d suggest that the replaced anm should at least start with the same geometry, and then alter it from there after you get the import working.

Yeah, the inconvenience compared to Titan Quest is that the majority of the creature meshes had compatible animations because the bone names were consistent.
(left forearm = Bone_R_ForeArm on most creature .msh)

Yes, like corpse weapons ala Blighttown monsters from Dark Souls :slight_smile:

So no one has figured out what to do with mif files once you have your points?

That still seems to be the state of affairs. I couldn’t get any of 3 meshes to import, couldn’t extract and import, etc. No news from anyone else yet either. Editing the points in an asset already imported, I haven’t tried to see if I can make the green gas come out of the back or something.

Waiting for tool updates and bug fixes before I even attempt anything. :stuck_out_tongue:

Updated the original post to be more thorough and oriented to Viewer use.