FG - Black screen

Hello,
I have a black screen problem after loading the character. This only happens if I activate the “Forgotten Gods” DLC.

Dagnor

Try verifying the game files.

Hello,
I used “Repair.exe” without success. I have also uninstalled / reinstalled the game still without success.

Is it a brand new character?

I have the problem with my old characters.
I also created a new character that doesn’t change anything.
The only solution for the moment is to deactivate the DLC FG.

Curious. You own and have AoM installed correct?

Hello,
I bought it on Steam and installed it through Steam.

After having uninstalled / reinstalled the game, it crashes when loading after selecting the character.
I cannot attach the crash report because I am a new user.

That wasn’t what he asked. powbam asked if you have the Ashes of Malmouth expansion installed since it’s required to be able to play Forgotten Gods.

Sorry to have answered next to the easter.
I installed Ashes of Malmouth => OK
Then I installed Forgotten Gods => KO (the game crashes during the loading phase after choosing my character).

Hello,
I tried :

  • re-instalation of the graphics card drivers.
  • in the “option.txt” file to put “UPnPEnable = false”
  • to put “Grim dawn.exe” as administrator.
  • Re install the game
    It still does not work.

My config:

System Information

  Time of this report: 1/11/2021, 18:28:20
     Operating System: Windows 10 Famille 64-bit (10.0, Build 19042) (19041.vb_release.191206-1406)
             Language: French (Regional Setting: French)
            Processor: AMD Ryzen 5 3600X 6-Core Processor              (12 CPUs), ~3.8GHz
               Memory: 16384MB RAM
  Available OS Memory: 16292MB RAM

DirectX Database Version: 1.0.8
DxDiag Version: 10.00.19041.0546 64bit Unicode


DxDiag Notes

  Display Tab 1: No problems found.
    Sound Tab 1: No problems found.
    Sound Tab 2: No problems found.
    Sound Tab 3: No problems found.
      Input Tab: No problems found.

Display Devices

       Card name: NVIDIA GeForce RTX 3070
    Manufacturer: NVIDIA
       Chip type: GeForce RTX 3070
       Current Mode: 3440 x 1440 (32 bit) (144Hz)
  Driver Version: 27.21.14.6089

Hello,
I have installed the game on two other computers and there is the same problem.

Tried redownloading a new copy of the program? Might be a problem with the original d/l.

Hello,
I ended up identifying the origin of the problem. It was the backups.
To solve the black screen problem I went to the options, network tab. I clicked on “download backup”, then I clicked on “perform cloud backup”. After leaving the options window a new window opens asking if you want to recover the local backup, answer “yes”.
And miraculously there is no more black screen.
Thank you all for your responses.

1 Like

Thanks for returning with a solution which might help others. I wouldn’t guess this solved the problem.

Just to clarify this for future readers: your “download backup” is actually your Download Cloud Saves button, and your “perform cloud backup” is the Delete Cloud Saves button.

What you really did was download the cloud saves. This places them into local saving. Then you deleted the files in your cloud saves. Then…

…if you delete your cloud saves , which you did, and then back out of the options screen to the Main Menu you get this prompt asking you to import your local saves - if your local saves has save files in it, which, you just downloaded your cloud files into this location so they existed there.

Indeed. What you just did, all told, is you downloaded your cloud saves and then UPLOADED the same exact files that you had in the cloud, immediately BACK into the cloud. And it somehow fixed a black screen problem.

Trust me, I’m very confused too :upside_down_face: All I can guess is that some weird sync issue occurred at some point and doing what you did “fixed” it… somehow.

Hello,
Please excuse me for the error I did not reread myself.
Here are the steps taken:
1-I clicked on the “Download Cloud Saves” button of the “Network” tab in the options.
2-I clicked on the “Delete Cloud Saves” button
3- I closed the options window by clicking on the “cancel” button. This opens a new window asking if you want to import the local backups. I answered “yes”.

On my old laptop I still have the problem. I will redo the manipulation, noting all the steps.