Gamma/Brightness bug

Hello everyone,

For some time now I’ve been getting this weird bug that happens every time I launch the game…
My screen settings get a boost in gamma without any monitor/screen/graphics card settings actually being changed… everything seems to have a “white-fog” filter and is super bright, it happens every time I launch the game and the change still stays after closing the game down, sometimes it doesn’t happen until I close the game (white brightness flash appears when the game closes down and turns my desktop/videos/other games into full brightness mode) or when I change the game from borderless-windowed to fullscreen (and the other way round)…
I have tried reinstalling, verifying game files, playing around with the settings and it keeps happening… It’s not that big of a deal when I want to play really (other than the fact that the game is ultra bright without me touching the gamma slider), but when I want to stop playing and watch a movie or do anything else I have to restart my pc just so the brightness effect disappears… It is getting quite annoying >.>

Could someone from the dev team look into this? I will post my pc specs below!
Thank you for your time!

PC Specs:
Graphics Chipset - AMD Radeon ™ R9 380 Series
Memory Size - 4096 MB
Memory Type - GDDR5
Core Clock - 990 MHz
Windows Version - Windows 8.1 (64 bit)
System Memory - 12 GB
CPU Type - Intel® Core™ i5-4590 CPU @ 3.30GHz

P.S.: I haven’t messed with the drivers as I didn’t have this issue before one of the latest patches(I did take quite a long break from playing the game but I remember playing for the last time when the black/silver knight skins came out) > maybe one of those patches affected some brightness settings? (idk)
Thank you again for your time!

So this is an issue I’ve had myself for a long time with several games (it seems to have finally been fixed with a recent Windows 10 update).

Basically what happens is that the gamma/brightness settings get overridden by Windows and the only way to undo it is to go into the Nvidia/AMD panel and resetting them there. I do not have an AMD card so I don’t know where in the panel you need to go, but this is what it looks like for NVidia. Simply flipping that setting on and off will reset the override and the display should be normal for the rest of the session.

Could you perhaps replace that setting with a postprocessing shader? That way it’d also work in borderless fullscreen…

Thanks a lot for the quick response! I went into my amd panel, and managed to fix it by going into the display color> settings and changed the sliders around back to the normal!

Have a nice day! <3

So does that have to be done every time you restart your PC Zantai?

Probably, I will try right now, it fixed the brightness issue but i started the game up again. >
Oh yeah I closed the game and the brightness changed again… guess I need to do this every time I close the game…

So uhm, the brightness issue is fixed when “recalabrating display colour settings” but the brightness change happens every time I close grim dawn… so i have to do it every time I close the game so I have normal brightness again…

The thing with the gamma slider in game too: the slider only works for full screen mode, but when i change it in fullscreen to “default” (middle) and then change to windowed borderless -> then back to fullscreen, the game buffs the gamma that the “default” (middle of the slider) isn’t the brightness it was before, the gamma itself is skyrocketed to the beyond again… and the only way to fix it is to close the game> fix the brightness using amd control panel>recalibrate colour settings> start the game up and not touch the settings at all… It’s quite annoying, especially when I really don’t like playing in fullscreen as I have to tab out and when I do that in fullscreen mode, the tab just spazzes out and I have to repeat the tabbing out process multiple times for it to work…

Edit: this doesn’t happen in any other game btw, just grim dawn… is grim dawn supposed to overwrite screen colour/gamma settings? I don’t have this kind of issue with any other game when chaning gamma/brightness etc.

Hello again, so what I figured out is: the gamma slider in game changes the monitor gamma settings itself without any “actual” changes to the settings themselves… why is the gamma slider in-game affecting monitor settings instead of the game settings? Could you explain this to me? Everytime I start up the game> touch the slider in fullscreen OR borderless mode the gamma changes instantly without me using the slider (just clicking in the middle of it) all of a sudden the game is doubled in brightness and my monitor too… and whenever I don’t touch it, its fine… until I close the game that is… because then the monitor settings change wether I touched anything or not.

I did not read all. If this is the same phenomenon i experienced, then you can try just go windows desktop and back in game. That fixes my gamma.

Maybe this one is different, but I got a gamma/brightness related bug (ingame adjustment slider). See, sometimes in some lighting conditions in my environment some ingame areas are too dark (like Chtonian areas behind a portal in Mourndale). So in such cases I go to settings and attempt to adjust that slider, and there are two weird things often happening:

  1. While current state of a slider is definitely above 50% (saved from some previous game launch), it looks like actual brightness is in fact 50% (default), and when I click anywhere on that slider, its value is probably immediately recalculated, and it then applies a proper brightness accordingly. Then this reoccurs the next time I run the game.
  2. When I change slider state, sometimes the whole screen turns into colored grainy mess with anything barely visible (you can still guess placement of actual UI elements if you got a sharp eye). This can be fixed by resetting video mode (switch resolution back and forth, OR toggling vsync setting, OR alt+enter to switch between fullscreen, windowed and back). Not a dealbreaker, but annoying AF.

Specs: Optimus enabled laptop (GeForce 960m), Windows 10 pro current latest build.
I think it is the Optimus to blame here… Getting a new laptop soon anyways…

Edit: the 2nd one definitely does not occur on my desktop PC with gtx 1070ti onboard, not sure about the 1st one, gotta recheck later…