Help! 5-second stutter in game

So a friend of mine is playing GD with me and my wife, and she has an i7 6700 processor (8-core 2.6 GHz), Windows 10 64 bit system with 16 GB of DDR4, and a Geforce GTX 1060.

She’s having an issue with the game freezing up for exactly 5 seconds when the following things occur:

  1. Any large particle effect occurs, such as Olexra’s Flash Freeze, Meteor Shower, etc.

  2. Objects come out of a lock box/treasure chest.

We’ve tried:

  • Forcing the game to use the GPU through the Nvidia control panel
  • Setting power management to prefer maximum performance, both in global settings as well as application settings
  • Vsync turned on in control panel but is set to off in game (we tried the other way around, and then only having it on in game and off in control panel but we got screen tear and/or even more stuttering issues)
  • Lighting to low
  • Shadow to low
  • Shaders to low
  • Particles to low
  • AA to 4x

Nothing so far has worked, and I am running out of ideas. Has anyone here experienced this problem, and if so, what have you guys done to fix it?

Please don’t get your hopes up with this reply as I haven’t got the foggiest :confused: , just a few questions in the random hope it might help somehow

  • Is this playing in MP or SP or both ?
  • If MP, does it change if she is the host / guest ?
  • Have you verified the game files via Steam ?
  • Have you run ALL (x86 & x64) the installers in the GD install folder steamapps\Common\Grim Dawn_CommonRedist.
  • Tried the Repair.exe in the GD install folder ?
  • Cloud or Local saving (set in both GD options and Steam) ?
  • Is she using OneDrive ?
  • Is it Steam or GOG ?

keep v-sync on in the game , anti aliasing off , alpha to coverage off, triple buffering off , anisotropic filtering off and windows borderless.

Try this.

Sorry to say but you won’t fix sluttering with anything, it’s the engine that is not optimized, tried so many rigs lately, very high end hardware, tried all possible solutions, methods… gave me headaches, some people got small slutter time to time, some more, like you. 5 seconds? That’s absolutely inacceptable.

Grim Dawn is one of the best ARPG’s out there, but the engine is really…meh. It’s really the only thing I can rant about this game.

Sorry to the devs, I know how much love they put in GD, but you really have, at some point, optimize the damn thing.

Yeah, but you have to, at some point, realize that saying “optimize it”, as if the word alone is something you even understand when you clearly don’t, doesn’t even mean anything. They have “optimized” the best they could over the course of development and after, within the means of the engine.

When you say “optimize” what you really mean, without realizing it, is hey Crate, scrap the entire engine that the game was built on and start over. Which, we all know, isn’t going to happen as they would then have to basically rebuild the entire foundation the game sits upon. It took them how many years to get to this point as it is? And what the rest of us know, is that is what it would take to get the kind of optimization you are imagining in your brain.

On the upside, they are already “optimizing” it by upgrading from DX9 to DX11, as part of their Xbone port.

But 5 second lag/stutters? I don’t see that. Never. That speaks to me of something else going on with the persons rig. What? I dunno but I’d be looking closer to home. Could be anything. Bad system settings/tweaks/OC/UC, BIOS settings, rogue background programs running, malware. Anything.

GD is optimzed, there is always room for improvement and better multi-core support would be great, but it is not like this is such an unoptimized mess that long pauses are frequent and widespread.

If the game pauses for 5 seconds that is so far outside the norm that you cannot blame this on missing optimization, that is something specific to that machine.

I also have a core i7 processor.

Two things come to mind:

  1. Disable hyperthreading in bios. It’s not a panacea but it helps.
  2. What antivirus/firewall are she using?. She could try running the game after disabling both for a while.

When it’s such a blatantly excessive time of 5 seconds…then it’s NOT the engine, and stating “nothing you can do, live with it” is not very helpful in the slightest.

  • Both.
  • Doesn’t change.
  • Yes we have verified her files, no change.
  • I am not sure what you mean by running all installers, could you clarify?
  • Yes we have repaired, no change.
  • Cloud sync is off in Steam, cloud saving also off in GD options.
  • Not using OneDrive.
  • On Steam.

This configuration causes massive screen tear for some odd reason. She ended up hitting the “default” button in GD options, and the screen tear stopped.

Also, she has an integrated graphics card in her rig as well as the GTX 1060 card. Now, in the game options, the rendering device shown reads “Geforce GTX 1060”, but is it possible that the game may be also seeing the integrated card (even though it doesn’t show up in game options), and is perhaps trying to hand off the rendering load to the integrated card, causing some (or all) of the 5-second lag?


We’ve smoothed out the screen tearing, and brought the lag from the stutter from 5 seconds, down to 3 seconds (I had her copy my Nvidia app settings for global and program). The lockup/lag still happens every couple of seconds, however.

A new wrinkle we’ve found is that whenever she mouses over items, the game gives that same lag, as though the game’s having problems with rendering tooltips or something I’m guessing.

The game also seems to want to lock up/lag when she fights larger enemies, like bosses. The bigger, the more frequent the lag spikes. Card overheating, maybe?

What the hell’s wrong with this game? Her rig is superior to mine, yet her performance is magnitudes worse.

Pretty soon successive generations of computer hardware will simply not be able to even RUN GD.

No problems. In the same folder as the Repair.exe is a folder called _CommonRedist. with 3 folders inside (DirectX, DotNet and vcredist) with various installers inside them…DirectX is setup.exe

It’s worth running all of them, though you might not need the DotNet with Windows 10 (Windows will say if it’s already installed) and with the vcredist folder you’ll need to run both the vcredist_x64 and vcredist_x86 in the 3 folders 2010, 2012 and 2015.

No guarantee this will help, but it won’t hurt.

Does she have many other programs running while playing GD, as could try turning the Background FPS slider in GD options all the way down (to the left)

Do you have SSD or regular hard drive ?

It might also come from other software as mail sync, or other itunes or anything might use cpu/internet connection in same time. Try to go to task manager and kill all other useless program. Nvidia experience are quite ram consuming sometimes. (no idea about amd stuff)

Also if yo have some spare stuff. Try to mount a temporary clean install with only Operating System, drivers and grim dawn. Takes times but then you are sure.

I do have almost the same rig as you and it runs very well. Had some frame rates down sometimes but I did max all settings and never had some freeze or lags even on MP LAN.

Also, what about corpses persistence setting ?

Try to do clean install of GPU drivers and if needed, uninstall graphic card and do a clean install afterwards.

Computers are great … when it works