Issues with Screenshots...

Hey all!

I’m fairly new to the game. My wife and I bought this game around Thanksgiving to play together. At least that is how it started out. Then I fell in love with the game! With that being said, I use the Fandom wiki site a lot for learning where all the bounty quests are. One of them was rather vague and wanted to help out some. Only to my horror to see my screenshots look like scrabbled TV reception. As far as I can tell, this is the only game doing it. Sims 4 screenshots are fine and when I played WoW, those were fine. Same PC,keyboard, mouse that are in use still, too. Any ideas how to fix this or why it’s doing that? Thanks for any assistance you can provide!

  1. run game in window mode or
  2. change resolution in Nvidia Control Center*
  3. If you are using steam to make screenshots with f12 than u could try to turn on steam overlay.

Are you using a laptop to play Grim Dawn? Most likely due using a different resolution where the aspect ratiosis less common.

Hello Daalon and welcome,

That’s because of DX11!

The engine is using DX11 as standard.

If you are using Win10, then you can use the WIN+Druck function.

But then the pic will be found under <c:\Users[your name]\Pictures\Screenshots&gt;!

No, I run everything on full screen.

  1. Thanks! Looking at that now!

3.) Just using the print scree/Sysrq key, as I do in all other games. Not sure why this one would be different. Then again, I’m pretty computer dumb. :slight_smile:

Looking at the NVIDIA Control Center, it is supposed to be using video cards setting, which should be 3440x1440 (Loving my DELL 46" wide curved monitor!)

Thanks for the welcoming! Love the game! Just finished the base game last night! It was AWESOME!! :slight_smile:

Sorry, but what is Druck? Googled it and even google failed me. hehe. Sorry, not very knowledgeable about PC stuff. Know enough to kill one on accident, but not enough to fix all my issues. At least that is how my cousin described my ability while fixing my screw up once. :stuck_out_tongue: Yes, I do have WIN10, though. Thanks again for both of your help!

OK, so changed the NVIDIA Control Centers settings and it still comes out like the original post. However, as Mauricius suggested, Steam allows me to use the F12 key for screenshots. So, at least now, hopefully, I can post and help out on the FANDOM wiki page for this game. That’s really what my interest behind this was/is. Thank you both for taking the time out to help me with this issue!

Yes! :slight_smile:

Sorry, I meant the button “Print Screen” (Prt Sc) … “Druck” is the german designation for that. :wink: