Light bleeding through walls\objects

v. (x64) DX11 Deferred Rendering - light bleeds under\through walls\objects when staying close.

Round thing

UPD: Problem occurs not only with Deffered Rendering, but shadows settings on “very high” and “ultra”.

Same areas marked:

Well marked
Column marked
Wall marked

i dont really understand, you know that chars have a light radius themselves?

1 Like

Have you seen screenshots?
Maybe i need to mark those areas, but i thought they quite obvious.
Look at the narrow bright areas behind (under - in terms of 2D) round well, column and wall.
Yes, it’s light from char (btw normal - without light radius modifiers) but it’s not supposed to be in that areas.

I am really trying. Maybe i have seen grim dawn for so long it all seems normal to me. Marking them would help me where to look.

OK, here you go:

Well marked
Column marked
Wall marked

ah yes

a small detail. but yeah visible none the less. its like the objects are floating. I think its the way they make the ground look to be neatly going into the object that causes this. As if a separate piece of ground edge gets lit up by the light radius. well spotted.

It’s clearly visible in motion, since light is from char.
Guess it wasn’t here before deferred render or even latest update - didn’t noticed it myself.
Quite possible it’s exclusively deferred render artifacts, since its designed to render standalone parts of scene and compose final picture afterwards.

UPD: Just checked now.
It’s not only Deffered Rendering artifacts.
Less apparent without it, but still quite noticable.
Shadow settings should be on “very high” or “ultra”, otherwise there will be no realtime casted shadow to see this.

V1.1.6.0 (x64) the problem is still persists

I love Grim Dawn and hate to point out its flaws. But i can’t just overlook such eyesore.
Its pain to see this every time. Its need to be addressed.

Here’s some more obvious examples: