Mill workers don't deliver flour - 0.7.4

Since the mill received a second work slot, they don’t offload their flour anymore. Instead, when the storage of the mill is filled with flour, they go “unable to work” even though there is an empty granary nearby that accepts flour.

This was from a long running save so I have not tested if this is still an issue with games that are started with the newest patch.


Does the issue persist upon reloading? I cannot reproduce this. They are dropping off flour just fine.

Hey, I did have the same issue on my latest save. Neither wheat nor flour would be delivered.

Here is my savefile and map:

Edit: I did not try after reloading

I will check it again when I am able, maybe it will be solved upon reloading.

Edit: Just reloaded the save and the issue persists, but it is not constant. When the mill is full with flour but not with grain (and the barrel icon doesn’t appear), they drop off flour just fine. But when there is a lot of flour and a lot of grain, sometimes they stop working, and the barrel icon is over the mill.

The issue seems to be that if the threshold is reached where the barrel icon shows, they don’t drop off flour anymore but they do drop it off before that. I had the filled granary right next to the mill, maybe the very short walk to supply the mill is causing problems.

I also have a problem with the mill since recent.
There are 2k wheat next to in the silo, but the mill is no longer supplied, it remains at 7 wheat for years.

Have tried sending all workers away, as well as moving the mill. Both without success.

Have noticed that in the mill was obviously no “heavy tools” none. For whatever reason.
Which is strange, because you need some to build.
Couldn’t put one in either though.

Disassembled the mill and built a new one. And lo and behold, everything is fine again.

Since I definitely didn’t do anything to the mill, this must be a bug.
Maybe this info will help someone.

You were able to build the mill ? for some reason it is never built. [0.7.4] V

Do you have the heavy tools it needs? Have to get those from a trader.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.