Missing Equipped Items

Several times within the past couple of weeks I’ve loaded up campaign with my character and items that I had equipped on my character are missing. They aren’t in any of my inventory bags nor are they in my GD Item Assistant stash (gloves two times, and chest piece).

FYI, Im using GD Item Assistant, GD Internals, and I’ve disabled Steam cloud saves.

Hoping someone has an answer as to whether these items can be recovered (previous save?), and how to prevent this from continuing to happen. Thanks!

Welcome to the forum. :slightly_smiling_face:

Were you using cloud saving and have now disabled it? And did you disable it in both the Steam settings and the ingame options menu?

Thanks and thanks for replying! Yes, I have disabled Cloud settings both in Steam and in-game. That was done when I first started playing the game. Im about 100 hours in now. This issue only started popping up within the last two weeks or so.

Strange, local saves shouldn’t be a problem. Have you verified the game files?

I hadn’t since the last update. I just ran it and it said all files were validated successfully. I can keep an eye on it to see if that helps.

Just an update, I booted up the game to play today and my chest armor and primary weapon were missing. Any other possible solutions to this? Seems to be happening pretty frequently now. Its only been happening since the last update.

I just closed and re-opened the game, and now my boots are also missing.

  • Which expansions do you play with?
  • Is this happening in single player mode or in multiplayer? If the latter, are you the host or are you joining other people’s games?
  • How frequently does it happen? Can you try to reproduce it without using GDIA and GI?
  • Have you checked if there are updates for these utilities?

A Similar Thing happened to me on Friday - almost all of my Equipped Items are missing, plus some in Stash and Inventory (see the gaps in my stash in the Screenshot?)

I’m using:
Grim Dawn + AoM + FG + Cruc
GD Item Assistant
GD Internals
Rainbow Mod

I play exclusively in Singleplayer

When I first encountered the problem, my Off-Hand wasnt missing yet, but now its gone as well.

Cloud Save disabled ingame and in Steam (since one or two weeks at least)
I successfully verified the files.

Screenshot: https://imgur.com/a/YvoGgMV

I equipped some Dummy Items now to check if the problem persists, and i’ll keep you updated

I’ve done some testing but havent been able to reproduce the issue consistently. I have a hunch that it might be caused by something with GD Item Assistant but I dont know for sure. I have been doing the following the past couple of days and havent seen the issue yet…

  1. I make sure to load up my game and start a session before I open GD Item Assistant.
  2. When Im finished I make sure to close GD Item Assistant before I exit out of my session.

Again, not sure this is a solution but I havent seen the issue since I started doing this. Also an FYI… GD Item Assistant released an update in the past couple of days might be worth updating.

  • Which expansions do you play with?
    AoM, FG, and Crucible

  • Is this happening in single player mode or in multiplayer? If the latter, are you the host or are you joining other people’s games?
    I Only play singleplayer

  • How frequently does it happen? Can you try to reproduce it without using GDIA and GI?
    Hard to tell, not very consistent but it happened three times over the past week. I have not been able to reproduce it consistently.

  • Have you checked if there are updates for these utilities?
    They were all up to date at the time these happened. GD Item Assistant has released a new update within the last day or so. I will make sure to update it.

Well, since you’re using GD Item Assistant you might find your missing items in the backups it creates in ZIP files in %localappdata%\EvilSoft\IAGD\backup (just copy that path into Windows Explorer)…

But I very much doubt GDIA could cause missing equipment on your character when it only manipulates the stash, which is a file separate from all your characters…

I had the same thing happen to me! I turned off all mods just to be safe and both cloud saves are OFF. If I turn on the cloud, I’m back to level 38 with steam or level 47 with GI. If I turn them off I"m at level 56. I’m completely confused. I’ve also lost any and ALL pants in the game. Can’t equip anything. My entire necromancer abilities are gone but my points are still there. The NPC who lets you reset your points is also gone. Any ideas what to do?!

I started up GD today and my main character has lost all of his necromancer abilities. The points are still there but everything is at “zero” and unusable. I’ve also lost ALL pants in the game. They don’t exist in shops and I can’t equip any. The NPC who reset’s your ability points isn’t in the game anywhere. I’ve tried every possible way to start the game. When I turn the cloud on steam, I"m sent back to level 38. When I turn it off on both steam and GD I"m 47. When I turn it off on Steam, GD and launch from the GI mod, I"m 56 with all the problems. I just finished the Malmouth expansion last night and rifted back to Devil’s Crossing.

I"m including screenshots. I’ve never had any issues until today. I even tried starting on Elite or Veteran and it’s the same issues. Please help. I’m on version 1.1.7.0

Imgur
Imgur

It won’t let me upload my DxDiag because I’m a new user.

Here is the third screenshot. I’m a new user so I wasn’t allowed to post more.

Imgur

No need for a separate thread.

When you start the Ashes of Malmouth storyline by talking to Creed and watching the cutscene, the Spirit Guide in Devil’s Crossing vanishes. If you talk to some NPCs, it’s explained that she sacrifices herself to stop the assault on the prison and her tombstone (along with a few other casualties) can be found next to the training dummies.

If you need a Spirit Guide desperately, there’s one in the Coven of Ugdenbog, Conclave of the Three and Crucible.

If you’re on 1.1.7.0 then update to 1.1.7.1 which is the latest version of the game. GI only works with the latest versions.

I already went to them and it’s the same result. I can’t reset or access any of my necromancer points.

Sorry that was my mistake. I’m on 1.1.7.1 version of the game.

Have you tried verifying your game files? Preferably without any mods like Grim Internals installed/active.

Do the issues persist if you launch the game without any mods like Grim Internals active?