NTQV3 - Grim Dawn, Titan Quest, Diablo 2 & RESSURECTED stasher

Win10 I use is x64.

Look at the picture you attached,
I think that there is nothing wrong about the display of Japanese.

Even if I use it in English or Russian, my NTQV does not seem to work,
There seems to be a cause for something in my own usage or environment of use.

If I find additional information, I’ll let you report it again.

Thank you

look at attached image, is these features disabled (checked lower options)?

it’s items-auto-gatherer on/off switch and its sound switch
(sorry, i no translate they yet)
i found it contains a bug with new game characters, temporary solution - in game the personal stash must be opened at least once for each character
i will fix it in next build

fixed the error described above
added localization of previously missed labels

new link in 1st post

I tried it immediately, but unfortunately the situation seems to have not changed.
The GD person works somewhat, but the TQ person can not even select it.

I also tried other Japanese players,
Even when TQ was chosen, no error appeared, so it seems that the cause is still on my side.

I do not know whether it is helpful but attach tqdebug.txt that was output to the folder.

For the tags you’ve added, we will proceed with the translation work,
I will translate and feed back the tags that will be added in the future as much as possible.

so… you play in TQ…
i doubt that may be something wrong with your system/game. that just ntqv’s (my) bugs-)

please, tell me your step-by-step actions.

  • i suppose program started normal?
  • transfer stash drawing?
  • TQ characters names shown in list?

about drawing tq’s characters inventory - this is not yet implemented.
this feature is added for experimental purposes and only for GD (as auto-gatherer too)

now i testing it for TQ.

ok, TQ’s characters viewer & auto-gatherer is ready.

Thank you for prompt response

These are results for the 1204 version.

>>- i suppose program started normal?
When GD is selected, it will start up normally.
If you try to select TQ, it will look like the attached image.

As long as "<add key = "LastGame" value = "TQ" />" is not corrected to "<add key = "LastGame" value = "GD" />"
It will end concurrently with startup.

>>- transfer stash drawing?
Yes for GD, but for TQ
There is the above problem and it has not been able to proceed to that stage.

>>- TQ characters names shown in list?
For this same reason for No,
However, if the above problem is solved, this will naturally be solved as well.

After going home, I will try the 1205 version.

send to me file “nTQV.exe.Config” please

I’m sorry to be late, I will send you a file.

please try that build:

i added exception catch in function of change a game

feel well.

Although it does not act, even if TQ is selected, forced termination does not occur.
After that you may be able to work if you modify the reference settings.

Upload screen capture and debug and configuration files.

you may to not send tqdebug.txt, it’s a junk from SoulSeekkor’s TQVault core)

here new build with extended errors description:

(I begin to suspect that the problem with finding folders with the game)

As expected, if you use AppID for folder detection,
It may be related whether you have installed an old titan quest or not.

Each AppID,
Titan Quest: 4540
itan Quest Immortal Throne: 4550

Currently TQ and TQIT have been deleted but old files somewhere on my PC
It may be that it is affected by remaining.

TQIT is different from Ragnarok and AoM
A format that installs clients independent of Titanquest was adopted.
That may also be one of the causes.

It is additional information.
TQ, TQIT, TQAE, TQRA all installed,
In the case of a player who has not been deleted either
The same phenomenon as me does not seem to occur.

i understand nothing.
tq’s page of ntqv opens now?
if not, what shown on screen?

Have you tried to run ntqv on another machine with another set of installed games?

>>if not, what shown on screen?
A large amount of error text is displayed like the attached image.

>>Have you tried to run ntqv on another machine with another set of installed games?
I tried it with two PCs.
Case 1 has never installed TQIT. Case 2 has installed TQIT in some cases.

Currently only TQAE and RAGNAROK are installed in both cases.
More problems are occurring in case 2 PC.

please, export the “HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Iron Lore” key from your registry and send it to me

seems, in at least one of subkeys with games in your registry there is no “install location” parameter

I will send a registry.
Since the extension txt has been added, if you delete it, it will be a reg file as it is.

In the past, similar events and coping methods related to TQvault were posted on TQwiki in Japan.
It seems that an event has occurred in the past when TQ of both package version and Steam version was installed.

I think the cause is similar to this case because it was a registry.

I will send you the source URL.
The place where “error loading resource” is written is the place of concern.

ok, thanks
it was an error reading keys from the registry
here a fixed build:

if there be all ok, i will renew link in first post