Problem with region pathing

Hi guys!

I have a problem with the pathing.

Everything was working fine but suddenly I can “walk” only on 2 regions out of 8 (in-game I mean).

I rebuilt the pathing a lot of times without success.

The only problem I can think of is that I hit “Pathing - First Pass” in the “editor mode” (which I don’t know what the heck it does XD).

Is this the problem or is it a bug or is it anything else?

Thanks for the help!

Have you check the x and y positions ?

Mhm… where do the regions have to be? What coords?

Because I moved them and if the coords matter then then that’s the problem.


Make sure all map edges are touching together. If there is a gap, you can’t walk through that obviously. Use the smooth tool along the touching map edges if you have to. Then, in Layout Mode, Ctrl+Click the regions you want and “Rebuild Selected Map”, then “Rebuild Selected Pathing”. I think that should do it.

Do you have any screenshots of the afflicted regions?

As I said I already built the pathing multiple times so that’s not the case and all the regions are correctly matching each other.

Could it be a problem with negative coords of the regions?

Negative coordinates don’t mean something, it’s just a number on the axes. It’s all relative to the starting point 0,0,0. If you put a region in one direction, the numbers are positive, if you put a region in the other direction, they are negative.

-Any screenshots that show the regions in layout view or the borders of the problematic regions in editor view?
-Are the debug lines around the regions green in editor view?
-Has the mod been built properly the last time you tried to build it?

Here’s some screenshots:

The problem is when I try to cross the bridge.
The character will stop exactely where there’s the green line (as you can see it’s green and not red).

You start in gt_region008

and when you cross the bridge you’ll go to gt_region002:

As you can see the “Z” coord is set to 0 for both regions.

But now I noticed something weird when I try to build the pathing:

Every region has the " \ " except for two regions which have " / ".

Could it be this the problem?
And if so how can I solve it? O.o

Nah, don’t worry about the slash/backslash thing. I’ve got half my regions / and half , and pathing works fine.

Everything looks ok, I think it’s a local issue with the arkovian flooring thingy. Turn off debug lines and make sure the objects/tiles are perfectly flush. I don’t know for sure if the game doesn’t like pathing on objects touching across regions or on the very edge of regions… you could try extending a piece over the edge of the region and check it out.

Also, is the rest of the region pathable? If you character.warpcursor through just across the bridge, can you walk on the rest of the region?

Edit: Are those walkways overlapping juuuust a little bit just after the green line, or am I seeing things?

What the…!!!

It was an overlapping thingie…

It’s soooooo annoying because everything was working fine till… I don’t know when…

Probably I moved some “pieces of the bridge” and it messed everything up <_<

I can walk on other regions with no problems now.

Thanks for the help!

Alright!!! Keep on mapping now!:smiley:

I now pay much attention when I’m selecting things, because you can unwillingly, and unknowingly move stuff that you’re not supposed to. At least the selection process itself is covered by “undo” so it’s not that bad in the end if you keep an eye on the ‘x objects selected’ info, but crtl-clicking stuff is how I work now, avoiding click dragging. Especially around lights and volume triggers…

Mhm… I have another bridge and it seems it’s a “region” problem because I can walk on one half of the bridge and not on the other (the region lines perfectly cut the bridge in half).

So maybe it’s really a problem with this kind of pathing.

It’s funny because now the other bridge works nicely while this last one no.

Ouch, that’s a tough one…

Thinking about this, I am guessing that each pathable object belongs to one region. And even though it may extend to another region, the pathing must be available on the other side so that it joins.

In this case, an object is shared across 3 regions, making matters more complicated. I would try rebuilding the path mesh from within the editor view and see if I got any lucky. Otherwise, I’d just move the whole bridge some meters to the side so that it falls within one region.

I generally avoid pathing in corners, I put a rock or a tree or a pond there, so that you never step in 3 maps in just a few steps.

Use >Region -> Rebuild Path Mesh
(bound to Ctrl+B)

Then go to View -> Path Mesh Preview to see whether areas are correctly connected between those regions.

Rebuild all Pathing in Layout Mode is especially terrible at its job. Never use it.

I have bridges and stuff going between Regions in Zenith, that don’t work with the Layout pathing but do work with region-by-region pathing.

Thanks guys!
I solved the problem.