[REL] Grimarillion v86

Playing Earth/Naidan with Core Dweller and Terracotta pets. It happens during an open vendor menu in Devils Crossing, when I close it the world has vanished and I have to open a riftgate for the world to reappear.

Sorry, anything more specific? How often does it happen? Does it matter which vendor you use or do all of them have the issue? What about smiths? Stash?

I assume you have the coredweller summoned, what if you unsummon it? Does the issue go away?

I don’t really have time to test it properly, when I go in game with coredweller, I run around for a minute and I check the DC vendor and nothing happens. I assume this means it doesn’t always happen or it has something to do with game settings.

It happens every once in awhile when I open skill menu but I cant tell y one time nothing happens, next time does. Never had it happen myself on anything else. Only fix was to make a teleport. Never tried to unsummon him, need to try that.

Continued the game in Homestead, summoned Coredweller only and the environment disappered after a short time. No NPC interaction whatsoever. Unsummoned Coredweller and the environment reappeared.
It seems to me now that the issue is quite random and infrequent and does not depend on location or NPC/Vendor interactions. The only common denominator I see is the summoned Coredweller. Once the glitch happens and is taken care of by unsummoning Coredweller or opening a riftgate, the glitch may not happen again for quite a while…
Sorry, that’s all I got.

tx for the tip that unsummoning works. Ive afraid that if it happens in the void…

Can you try something for me?

Make a backup of the grimarillion map file, then copy the levels file from from GDX2 (…Grim Dawn/gdx2/resources/levels.arc) and paste it into the mod resources (…Grim Dawn/mods/Grimarillion/resources/).

Tell me if the coredweller is still causing issues if you do this. I want to be sure to eliminate the custom map as a possible cause before I try to fix the coredweller model - which seems like it might be a possibility

Happy to try, but… where is the “grimarillion map file”, I looked thru the grimarillion folder and can’t find anything named as “map”. However, there is a “levels.arc” file…

Ah, you’re right. You don’t have to rename it then, my mistake. Just move the GDX2 levels.arc over after you make a backup of the grimarillion levels.arc file. I edited my last message if anyone else wants to try.

I did exactly as you instructed: backed up grimarillion levels.arc file and replaced it with GDX2 levels.arc file. When I start up Grim Dawn and load my 52 level Naidan/Earth, the game puts me at Vanilla and 0 levels, no Diablo/Zenith/TQ at all. So, I revert to the back-up levels.arc file… but: the game now is all Vanilla classes only, and every single one of my 40+ characters which are around level 50 are back at level 0 without any classes and only vanilla!
I reinstalled all of grimarillion 85a and no luck, I’m stuck in vanilla!

edit: after reinstalling grimarillion 85a, I checked the start up screen to make sure custom map option grimarillion was selected correctly, which it was, and after exiting that option my saves became normal again…

I think I’m happy with Coredweller as it is!

Did Ignus stop crafting shattered items in 85 and 85a? Grimarillion Item Color Coding File v85a color 03 (and 02) breaks Mazaan dialogue for new waystones, checked with and without.


Mazaan dialogue works fine without the Rainbow File, guess it’s something for @Matougi to look at.

Missing Shattered Affix items, I guess this is from updating GrimUI, I forgot to check this. Will be fixed in the next update (soon:tm:)

Sounds like you accidentally loaded the wrong mod instead. Switching the map wouldn’t cause you to lose any classes. Don’t worry about it, I’ll just have to check it out myself…

Grimarillion has some special conversations that differ from the original. I overlooked that when I created the Rainbow file. I’ve fixed them, so use the new Rainbow File.

v86 Changelog:
*Updated D3 mod to the newest version of Definitive Edition as of March 8 2023. (Definitive Edition Redefined V2 + monk/gutworm hotfixes)
*Updated Demon Hunter and Crusader art panels.
*Updated several class combo titles to prevent conflicts with new D3 titles.
*Fixed an issue with Herakles’ Club not having proper quality tags at low levels and scaling too much.
*Added a pet widget for the Scarab Ring summon.
*Made some minor tweaks to the Core Dweller’s mesh data in an attempt to curb any potential issues, whether or not it worked is another story.

MEGA
Nexus

2 Likes

Rainbow File updated for v86.

Edit: I forgot to update the class name, so I corrected it.
Edit2: Several files were vanilla, so they were corrected.

1 Like

Should this not say it allows dual wielding of melee weapons?
image

I am a bit lost with this:
Playing a dualwield Blademaster (Nightblade/Soldier) equipped with two Dermapteran Slicers.
I installed a Chipped Claw (flat physical damage) component for the main hand slicer and a Chilled Steel (flat cold damage) component for the off hand.
The new cold flat damage shows up in the damage tab, the physical damage does not:

I do not have any equipment, skill, or devotion that transmutes physical damage.

Can anyone tell me the reason for this?

1 Like

another thing:

The end of the description of “Legacy of Hades” is cut off.

grimquest_tags.txt (v86)


grimquest_tags_skillnames.txt (v80a)

Storm Mastery Skill Tree
00_LegacyofHades_03

Edit: The remainder of the description is on line 813.


Edit 2: There is an extra character (SThe…) at the beginning of the description of “Freezing Cyclone.”


00_FrezingCyclone_02

1 Like

No but it is missing consistency.
Let’s grab Nightblade’s skills
image
The first is a passive effect that requires two equipped melee weapons.

The second effect is a WPS skill, and thus not a passive (As in, the “passive” template), this means it triggers x% of the time. Because it functions that way, you can’t have it “you can dual wield melee weapons with it when this effect triggers”.

However, you do see in the orange text that it specifically says “This is a melee dual-wielding technique”, which is what your example is lacking, and should have. Though it should probably also have “x% weapon damage” instead of “x% Main Hand Damage” since it’s a dual-wield skill…