Steam won't start

I wasn’t sure where to make this but didn’t think it belonged in the ‘report bug’ section.


So I been playing GD a few months now, and finally just installed Grim Internals and Item Assistant, and both are working perfectly. In fact, my GD actually WAS crashing every now and then, until I installed those things… now it hasn’t crashed even once and I leave it paused over night. Maybe since cloud saving is off?

Anyway again, the problem now is that I went to run Dota2, and nothing happened, so I tried to run steam by itself and it won’t even attempt to run. I’m pretty sure I didn’t do anything to steam but just did the save offline option in GD options and turned off cloud saving.

Has anyone else experienced this, and is it an easy fix? Just figured I would ask here before I start messing with stuff. I imagine of all the people doing this I can’t be alone. I tried to do a quick search and saw lots of threads about GD not starting, but not Steam itself.

Appreciate any help, thanks!

Try excluding Steam itself from being checked by any anti-virus programmes you have.

Try checking in your Task Manager that there isn’t a lingering Steam process and end it forcefully if so, then try running Steam again.

Reinstall Steam? It takes 2 minutes. Before that also check propeties of Steam shortcut (assuming you’re using a shortcut). Try running steam.exe from Steam’s folder.

Reboot your computer. In the past anytime I had a problem with steam I had to reboot to fix it. Theres been a few updates to steam lately that can cause you problems if it hasnt given you the option to restart the launcher for steam. Reboot always fixes it for me.