Teleport/Environment hole

Haven’t used teleport much previously so not sure if this is a known issue. Got stuck with no way out

Similar to the report I made about disengage the other day, out of bounds teleport on an area with different (lower) elevation. Same as Eard, I didn’t get such issue for a long time and it happened 5min into playing the latest batch.
Did something change about movement skills with the addition of Evade ?

I managed to end up under these stairs in the Tomb of the Eldritch Sun.

I tried to use Masterful Rahn’s Might to dash from the spot where the mob in the screenshot is, around the corner to the upper floor. But instead of dashing up the stairs I ended up under them. Wasn’t able to get out, had to teleport back to the riftgate.

Cannot reproduce it though, maybe it happened because the stairs was full of enemies when I tried to dash upstairs.

Again using Masterful Rahn’s Might to dash right into a mob, this time I ended up between the cobblestone and the lava. Pretty much where that little hole in the ground is. This is in the Remnants of Korvan City, just NW of the Pit of Atonement.