[Tool] GD Stash

that error is occurring when the existing table is being removed to allow for the creation of the new one. So this sounds like a problem with your database (i.e. it is corrupted).

Assuming you have no items stored in it, simply delete C:\users\username\GDStash\db. If you do have stored items, just renamed it, e.g. to _db. That should get you over the import hump, but your items are then not in the new database, so after you have a functioning DB again, we will have to copy your items over from the old DB.

1 Like

it worked ! oh my god it worked !
thank you so much ! you’re a real life savior !

Did you have items stored in the DB ? In that case I will post instructions which files to copy over from the old DB (tomorrow morning my time, it is late today…) - or you could search this thread, pretty sure I already posted them once or twice :wink:

EDIT: I did…

I didn’t have anything stored in the DB, but it doesn’t matter anyway ; I just get items straight from the “Crafting” tab to the stash
But thanks for the instruction ! Might come in handy
Also, I just realized : the reason I got those errors earlier was because, before that, I deleted some files while cleaning up my drives, without knowing, so… yeah
Oops :sweat_smile:

This might not be the right place for this, but Mamba, I thought I’d ask if you have a similar mod for Titan Quest?

No, I only created this for GD, I have no TQ version. There used to be TQVault however (not sure if this is still being updated to the latest TQ…) and NTQV3 also supports TQ afaik (never tried it)

Hello, I just installed the newest version, imported the database but i have alot of items with transparent background, it seems like it should be green. I don’t know why it can’t find the rarity of some of my rare items.

I have used this tool for a long time, never had any issue.

I will need some examples here. The background color still should be based on the rarity, as before.

Here is a screenshot of it in version 1.50

And then in version 1.44

I don’t know what informations you need.

I am pretty new to using move to DB and then import again.
When i try and import an item it says 0 items stored in stash. 1 items already in stash.?
I dont have it in my stash? (Thats kinda the reason for importing :smiley: )

I have no idea what you are doing. Move should simply delete the item from the shared stash (and store it in GD Stash’s database).

Not sure what you import. Are you going to the Config page and press Import ? There is no reason to do this… that imports the GD data, but you already have that…

If you want to retrieve the item, search for it on the left side of the Transfer screen, select an item from the result list and click on an empty spot in your shared stash

LOL ok thats how it works :smiley:

Not sure if I’ve run into a glitch or I’m simply doing something wrong. A chest piece dropped while I was playing and my game was not letting me pick it up so I’m resorting to GD stash so I can give myself the exact same chest piece but, as I try to go to the Char stash tab and try to search for the item nothing shows up. The only thing that actually shows are components and Quest items. Every time I search for anything else the results are blank. Has anyone came a across an issue like this, if so is there a work around?

The Transfer pages only show you what you have stored in the tool’s database. If you want to create an item you have not stored, go to the Crafting page.

this is fine, will be fixed in the next release. Thanks

Version 1.5.0a released

Fixes the issue with magical / rare items showing up as normal

1 Like

Guys, i’m really desperate cause i lost my GDS db file and now all my items from 250+ game hours disappeared.

Is there someone with the same (more or less) amount of hours on the game that would share his DB with me? Thanks a lot

Hey uh, when I make saves in GDS it doesn’t update the game at all when I restart game.

Cloud saves turned off

If you have cloud saves turned off, you do not even need to exit the game for the stash changes to become visible, you just have to ensure that the shared stash is closed while you make (save) the change.

So if you do not see the change, then the file GD Stash is changing is not the file Grim Dawn is reading.One way to easily verify this is to open the file in GDS again. If it still has your changes, it definitely is a different file.

Version 1.5.0b released

Added support for some Apocalypse templates (so Apocalypse chars can now be reset)