[Tool] GDModdingTool: Tool for making personal customized Mods

Hey no, the stats grow on a formula in the bio section. What I need is monsters to spawn again in the world. Lv101 character made all spawns stop. I don’t know what to do to fix this. Been looking all over and trying multiple things. Still nothin.
The last lines on the config_all seem to talk about monster spawning.

Is this still work?

@Paranoia
I had time to check couple of things you can change, like monster density and level scaling, and it seemed like it is working as expected. But some might be broken as someone said above.

@DoubleCannon
I am so sorry I missed your message, I got quite busy at work and didn’t even see it. I know it has been quite some time but I will try to check it this weekend and see if something is broken.

I tested this myself and even if I don’t change max levels, monsters do spawn. However the SetMonsterClassMaxPlayerLevel config was indeed broken. So I wondered if there was a patch that increased max levels. Indeed there was :smile:
This is from 1.1.9.0 patch notes:
[Mod Tools]

  • Default max level has been changed from 100 to 200 for the purpose of spawning monsters from Proxy Pools for mods that wish to substantially increase the max level.

So Crate actually helped you before I did :slight_smile: love Crate’s help in modding always.
Note that I will release the fix as soon as I check all the code if a similar bug is present in other config options as well.

Oh! You are here!! Thought this project abandoned (cause not update for a long time).
This tool helped newbies like me a lot!
I even find out how to modify the base game.
Thank you for your work!
Hope there is more update if you still play the game!
Cheers!

Can you also make an update for stasher mod? Thanks!

Sure, I will try to update tonight after work.

Stasher mod doesn’t seem to be updated. I have asked the author for permission for the other one you have linked. If you want it before, you just need to copy their files into the mod folder and build after that.

:laughing:Thanks for your update!!

And I have just one more question.
I still don’t understand the third option in the LOOT part.
Is this(below) right if I want a 10x legendary drop rate?
AdjustSpecificLootAmount 10 Amulet,Armor,Belt,Blueprint,Component,Medal,Potion,Quest,Relic,Ring,Shield,Weapon Legendary Ture

Yes that seems correct.

Howdy azakhi,

I was reading the documentation on github and didn’t understand one thing - is there support for modifying the quantity of rare materials for example? I see the valid keywords are [Amulet, Armor, Belt, Blueprint, Component, Medal, Potion, Quest, Relic, Ring, Shield, Weapon] - do materials (such as tainted brain matter, etc.) fall into any of those classes (maybe quest)?

Edit: This is really helpful, thanks for spending the time putting it together!

Edit2: Thanks a bunch!

Yes you should be able to go by colour to determine which one is it. Tainted brain is Quest.

The Commands in the Config file seem to be affecting another mod I already have installed for some reason.
Here is the Config File I’m trying to use to create my new mod. Do you have any idea what I might be doing wrong?

$RecordsDirectory
C:\Steam\steamapps\common\Grim Dawn\database\records

$ModDirectory
C:\Steam\steamapps\common\Grim Dawn\mods\TestMod\database\records

$SubDirectories
creatures
game
items
proxies
interactive

$Commands

More monster spawns

AdjustChampionChance 2
AdjustChampionSpawnAmount 2.5
AdjustCommonSpawnAmount 2
AdjustMonsterClassWeight 3 Hero

More and better loot

AdjustGoldDrop 5
AdjustLootAmount 3 All
AdjustSpecificLootAmount 10 Component,Blueprint,Quest Epic,Legendary,Quest False
AdjustAffixWeight 10 RareAffix RareAffix
AdjustAffixWeight 5 RareAffix NormalAffix
AdjustAffixWeight 5 NormalAffix RareAffix

Less XP and Reputation requirement

AdjustExpRequirement 0.10
AdjustFactionRepRequirements 0.15
SetAttributePointsPerLevel 5
ChangeSkillPointsPerLevelBy 2
SetMaxDevotionPoints 75
SetDevotionPointsPerShrine 5

Monster scaling

RemoveDifficultyLimits

Quality of life

SetItemStackLimit 500 Potion

How is the other mod installed? If it is installed by replacing existing game files instead of being a separate folder under Grim Dawn\mods, then this tool cannot separate it from base game. Which is a good thing imo.

How is it affecting the other mod?

Okay sorry about that. It actually isn’t affecting the other mod. It just isn’t affecting anything. I might be missing a step or two probably. Does it matter where your tool is installed at? I just have it in a folder on my desktop.

Nope, it doesn’t. Can you share the log file with me? It should be inside the folder where tool is located.

Never mind. I was just skipping the Build step with the AssetManager at the end. Thanks for the help.

So one more quick question if you don’t mind. Can large overhaul mods like Reign of Terror be modified with this? And if so do you need to use the Additional source file directory option in the config file? I looked for the source file directory in the Reign of Terror mod but could not find a records folder under the database folder.

You can definitely modify those but setting it up can be different depending on the mod. If you have located the database file (usually named as ModName.arz under database folder) but no records folder, it means you will have to extract them yourself. Once you extract them, you can give this folder as the Additional source file directory option. If the mod you you want to modify is installed under mods folder, you will need to merge it with the new files tool created. Simply copy the files tool created over to the original mod and replace when asked. This is because Grim Dawn allows only one mod to be active at one time.

Note that if Reign of Terror added new folders for itself under database/records, you may need to list those under $SubDirectories option, otherwise the tool wouldn’t read those.

Okay. So I just spent like 2 hours trying to extract the ReignOfTerror.arz and I don’t think that it is possible. I used this explanation on how to extract .arz files with the archivetool.exe [ https://steamcommunity.com/app/219990/discussions/1/1861616055079363190/ ] All it did was pop up with some error about an invalid file type. Some sort of .ccp file. I don’t know why it won’t extract this .arz file. All it did was add a new file called ReignOfTerror.arz-extract. So I don’t think it is possible to extract it for some reason. I also tried this same process with another mod I have installed to make sure that I was doing it correctly and the archive tool worked perfectly. But thanks a lot for all the help.