[Tool] Grim Dawn Item Assistant

Recently started using IA. Also having this redup issue. Is there a known solution?

Also another error with the “Nightblade” filter hiding Kuba chausses (w/ lethal assault).

I use translation to russian latest version. GD Item assistant show all on russian, BUT names of skills show on english. Why???
In game all text on russian.

P.S. reinstall prog repair it.

been getting duplicate issues lately as well. i do see an option to delete bugged duplicates but whats the difference between that and the merged duplicates?

Hmm. When I disable cloud saves, all my characters disappear! For other games the local files should be a duplicate of the cloud ones, so this is odd. But it also makes installing this mod more than problematical…

Welcome to the forum. :slightly_smiling_face:

The first thing you need to do is move your cloud saves to local saving.

Then turn off cloud saving in both the Steam settings and the ingame Options menu.

Ah, OK. In my limited experience with cloud saves in another game, they were locally shadowed automatically. Thanks.

There is no full russian translation of IA that I’m aware of, only partial.
It’s a job for the russian community translators =)

If you hop unto discord and send me an export of the file, I’ll look into it.

Since you can’t filter by more than 2 stats at a time, I’m trying to export to csv. However when viewing the DB, I don’t understand where the item stats are, can anyone help me there?

So today I noticed that when I transfer an item from IA in to stash I have multiple issues.
1 - If I do not have duplicates of the item (meaning only 1 available), the item will not disappear from IA. Even if I re-open.
2 - The only way to get an item to disappear from IA is if it has the “transfer all” option. The problem with this though, is that if I have 2 items available it transfers in anywhere from 6-26 items.

Any ideas?

Are you saying that IA duplicates items if you only have 1 to transfer?

Or does the UI simply not refresh? if you search again, is the item still there?

(Obs. I am no longer very active on the forum, only on discord)

Hello does someone know how to delete all items in GDIA with the exact same stats(duplicates) i know about ‘‘delete bugged duplicate’’ but thats not what i am looking for i really want delete every single items with the same stats since GDIA create a bug for me atm with duplicates

When i transfer items from IA to stash i close game, close GDIA reopen both same items are in stash but also in GDIA. If i dont close the game everything is normal.
I cant get items to disappear from IA and if transfer 1 item to stash and transfer back to IA it will be 2 same items in IA.
Every single time that i close and reopen the game while GDIA is active there is 2 process : parsing database and updating items stats i have not noticed that before.

I don’t have answers for you but you are aware that you can EDIT your previous posts right, rather than spam posting multiple times within a short time-frame?



I can chat in Discord if you prefer, but yes that is essentially my problem.

IF I transfer 1 item only, the quantity doesn’t go down and if it is just 1 item that I have, it doesn’t disappear.
If I “transfer all” it’s about 26+ items that xfer in to my stash lol

I have the same issues but even if i ‘‘transfer all’’ it wont disapear from GDIA. All the items reappear after closing/open GDIA again after this process in journal:
[01/02 22:03:04] DEBUG Backup initializing… (why ?)
[01/02 22:03:06] DEBUG Detected 3 items marked for removal ( the 3 items i transfered before closing/open GDIA)
[01/02 22:03:06] DEBUG Removal successful (3 items)
[01/02 21:18:07] DEBUG Updated/Merged in 4 items
[01/02 21:18:08] DEBUG Updated/Merged in 2 items
[01/02 21:18:09] DEBUG Updated/Merged in 1 items

Can someone help us please ?

I fixed the problem by making a local backup and going in ‘‘online backups’’- ‘‘details’’ section and delete online backup and then logout. I will do local backups now every week i guess. If it can help somebody.

I found a weird bug, I have an item in IA that won’t disappear, no matter how many times i take it out of IA and the stash, I tried to check by taking multiple items, and only this one so far, does that. Any idea what to do?

Edit: Apparently disabling online backup fixed it.

Although I’ve been warned that this program has its nose all up in your computer’s business I’m willing to try it since GD Stash made my brain bleed (I absolutely cannot understand how that works). However, my game is from GOG and I can’t seem to get IA to see my game files, so again I’m stuck. I found a couple videos from 2016 for GD Stash and nothing newish for this mod.

Is there anyone here that can talk to me like I’m a 4 year old and help me wrap my head around this and make it work? I’d be so grateful. Thanks!