[Tool] Grim Dawn Item Assistant

This is an awesome tool and I couldn’t play Grim Dawn without it. I was wondering if there would be a way to integrate part of Rainbow in the mod? I am not totally sure how it shows MI, got a couple of the same MI shields and the icon and background looks weird. I know it has a green and green + and ++. While a great sort, can we not just in the actual name have the Rainbow MI or DR tag?

Is IA compatible with Grimarillion? I have tried to add Grimarillion weapons(spears, for example), but they do not appear in IA. I have reloaded the Grimarillion database and closed/reopened IA, but the weapons still do not show up.

Try the filter in the upper right corner that says “Vanilla”

Hmm…it only finds 4 items and doesnt do any transfers. I even put items inside box 4 and walked away and its still there. Do I need to disable Cloud all the time? That messes with my character list since I must have messed that up too.

Uhg…figured it out. Cant use cloud storage which means I have like two different sets of characters depending if I enable or disable cloud…grr…

No, you don’t. You just need to move your cloud saves to local saving.

Doh! Thanks so much.

Also0 noticed that it uses shared stash tab 6 instead of 4…LOL

I see that after the latest update my charachters seem to be saved to the cloud. I sometimes play this game on different computers. Can i use this feature to not have to move my save files between the computers manually?

Sometimes errors like this appear:
[19-03 17:21:27] DEBUG Item transfer requested, arguments: StashTransferEventArgs[Prefix: Base:records/items/upgraded/gearweapons/caster/d002_scepter.dbr Suffix: Materia:records/items/materia/compa_purifiedsalt.dbr]
[19-03 17:21:27] WARN Could not find any items for the requested transfer

I was trying to transfer all of a certain unique item back to the stash. One of them had a purified salt component which seemed to be causing problems. After refreshing the item screen in assistant i was able to transfer them.

Thanks for a great app.

Can i use this feature to not have to move my save files between the computers manually?

Not automatically, but you can download your characters on the new PC manually and extract them to the save folder.

I’ll not be adding any automation to it, too many things that can go wrong.

Hi Pete, thanks for the great tool. I’ve used it a lot when I played GD in 2019 and was using the Online backup system at the time. Now I reinstalled GD and GDIA on a fresh computer, but even after logging in with the same email address the app doesn’t sync any items, suggesting that my online account has been wiped? I had possibly hundreds of legendaries and some high level characters too, so that makes me a bit sad :frowning: Has there been a wipe of online backups? My BuddyId is 124680, if that helps. Thanks for your answer!

Sorry for not responding sooner. I have tried selecting Grimarillion, but still did not see spears or other weapons.


I am using the latest version of GD Item Assistant on a GOG installation. Item Assistant itself is updating items placed in the appropriate slot for my top listed character from the Grim Dawn start screen only.

GD Item Assistant locates the Grim Dawn executable obviously, or it wouldn’t run at all. If you aren’t familiar with the GOG installation as opposed to the Steam installation I will break it down for you. The information that would be in the “Save” directory for all the characters, items, etc are saved in C:\Documents\MyGames\Grim Dawn\Save. The contents that you would find in the “Save” folder is identical to what you would find in the Steam installation.

I have cloud sharing turned off as well as the checkbox for sending anonymous usage statistic turned off.

I really can’t understand why Item Assistant would work perfectly for the character listed on my start screen, and no one else. I have six characters. If I go into the shared stash, it is entirely empty for all characters as it is for the top character that is listed when I start the game up. The only difference is if I’m using any other character than the one listed at the top when I start the game up is that I can’t place an item in the correct shared stash tab, walk away from my stash the appropriate distance, come back and have the item I placed get imported into Item Assistant.

So I’m hoping perhaps one of you might know the solution to my problem.

Thanks in advance for any help you can give me.

1 Like

How does the cloud charachter backup work if i have two pc? Is the cloud backup local to the pc it belonged to even if i play save files moved between the two computers manually?

Anytime IA detects a change to the character, it will perform a new backup, overwriting whichever cloud backup was there from before.

No logic involved, it’s meant as an emergency recovery feature in case of natural disasters like your cat ate your harddrive and similar.

I hate April Fools Day. lol

1 Like

Hello Does this work if i have download the game ? torrent

As a fellow moderator here said:

"Please do not tell me you are here on the game’s forum with a pirated copy.

And I mean that literally, do not tell me, just disappear until you have acquired the game via legitimate means."


Hello, apologies if this is off-topic, but I have been trying to write a GD save file parser based on your source code at https://github.com/marius00/iagd/tree/master/Parser.

I am able to extract the character name, level, gender, class and hardcore/softcore status (via the CharacterReader.ReadHeader() method), but attempts to extract further information (ReadCharacterInfo()) fail. I have had to bypass the version checks to get this test to work, I was wondering if the code doesn’t work for the latest version of Grim Dawn or if I’m doing something majorly wrong.

I can try and get my code up on GitHub if that helps, appreciate any advice you might have :+1:

No icons, skills do not connect to classes (no search in database by mod classes), no names for some items (xTag) on grimarillion. Loaded databases couple of times in opened and closed GD state - no changes. Is this normal work with mods, or do I miss something?