[Tool] Grim Internals

Like it says in the topmost post of this thread, “New Version v1.81 (x64) for GD v1.1.4.1”.

Why would you want to try 1.79 or 1.80 with it?

Firstly i tried the last version of GrimInternals v1.81 but can’t run after than i tried the others (1.80,1.79,1.78) but i’ve same problem.

My GD version is

No problems on my side with latest Version. Try again using the v1.81.


Yes, but are you trying to use it with x86 and not x64? If so, then yes, it’s not compatible. GI only works with the x64 version of the game. x86, 32 bit is no longer supported by the mod.

That’s logical ! Thx , i’m gonna fix that.

I entered the game and there is (x64) on the right bottom and still doesn’t working (GI)…whatever thx anyway

Start the game by executing GrimInternals64.exe, not the regular executable.

1 Like

you could also run the original exe first and then the GI executable it works too
most issues are from admin rights and AVs from what i still see

Hi guys, i need some help, i currently have some weird bug with “Tag not found: tagHUDhealth_head” that never happened before. Anybody know why ? I’m on steam with all dlc + lastest version of grim internal. here the pic

I’ve tried:

  • Reinstall (clean)
  • Delete all setting at Documents\My Games\Grim Dawn
    Thank you.

Using rainbow mod? If so, disable it.

1 Like

Why should he disable it?

All he has to do is update it. Then it will work like at all the other players.


i did, i already deleted the setting folder in my game/grim dawn or is it another step i have to completely disable the mod ? i just notice my game have double health bars, maybe it causing the bug ?

Nevermind, i found out game the base game have health bar now, i’m feel stupid lol, anyway thanks guys

Sorry for posting again, but is it actually possible to make the monster healthbars not overlap player healthbar? I’d really want to use the GI healthbars but the way they work now makes me rather use the new GD healthbars

Hello, I’m having trouble running the program, every time I start it appears a mismatch error.
Already tried to reinstall. And the version is the correct oneUntitled

Did you try to verify integrity of game files on Steam or similar thing on GoG? Do you have a 64 bit OS?

Yes i already checked the integrity and yes i have a 64 system

Hello and welcome!

Witch version has your GD on the main screen, in the corner bottom right?!

It must be v1.1.4.1!