[Tool] Grim Internals

Thanks for the reply and amazing work by the way. I actually finally figured it out this morning at like 6am. Somehow my save folders got out of whack with each other. I probably copied them over each other at some point and somehow I got two different characters with the same name, so I fixed that issue…sort of.

I got the mod to load and work. My main is there along with the other toon but when I select Crucible from the options, my main disappears. Crazy, this is after a fresh install and multiple restarts. I’m glad the mod is working but still no Crucible.

It’s gotta be a problem with the save files though. Thanks for the reply too!

1 Like

Crucible doesn’t work with mod characters by default.
By mod character I mean with mod flag checked (which can be seen in GDStash), visible in Custom Game only.
Unless you run GI with command line that enables Crucible for a mod (see OP)

1 Like

After I read your first post again, could it be that you want to play Crucible with your ‘Dawn of Masteries’ character?
So you start GI with the parameter ‘/Mod:DoM’ and your main campaign character disappeared?
That’s normal; you can’t play Crucible with your main char when GI has activated the Crucible-Mode for Custom mods…
Only custom mods characters are listed in the selection screen.

When you want to play Crucible with your main campaign character just start GI normal; without any parameter.

@tqFan You were faster… I was fiddling around with the Google Translator. :slight_smile:

1 Like

Hi, I’m having trouble getting the enemy names to show how I’d like. I want to see health bars for all enemies, but only names for bosses and nemesis (or just nemesis). I think I have the settings how they should be, but I still see all hero names too.

Is there hotkey to change game-speed without doing it manually with mouse? It would be so good.

There’s not but it can be done using other programs, see the first video in this thread showing in-game speed change with a keybind
[Tool] GDHacker 🕷 - Tribute & Exp Freeze / Game Speed / DPS window / Faster Camera PM / write in this thread for more info.

I think I updated it to public beta patch which I recommend (here how to set your game to in Steam Public Testing FAQ) so I’d probably need to give you version if you’re still using that.

1 Like

This is first time of me in the forums and well thanks for the Grim Internals tool it really helps me alot but im having a small issue tho its not gamebreaking but i feel it is better if i know how to fix the issue.

The issue is that when i play the game with the mod damage numbers that you deal to mobs aren’t shown like those text numbers that you see next to your character when damaging a mob. Sure grim internals do have dealt dps counter on the left part of the screen but it kinda distracts my eyes away from my character.

It would be greatly appreciated if someone showed me how to fix this issue thank you. And uh sorry if i have bad english like its not my main language so.

Will I be able to get the Halloween hat again? Any other special items other than this hat?

Grim Internals v1.99e for latest GD Public Playtest Build (September 26).
Download-Link (MEGA)

GI user should update to this version!


Yes, GI treats the names of heroes and bosses the same.

I’m not sure I understand correctly how the damage numbers should look like.

I have no plans yet to make a new halloween event…

I meant the old one. I lost it playing without internals one day.

Ok, with the next GI patch, the Salvage Dealer (Luther Graves) in DC will be selling the hat on Halloween.
Get it when it’s there … and don’t tell anyone! :grin:


Well this is cute. Someone apparently watched a certain episode of Portlandia and put a bird on it :bird: image


I recently started playing (again) and for some reason I can’t get any damage numbers to show anymore when using grim internals. I’ve got the dmg option on and been trying with swapping stuff on and off but nothing seems to work so far, any suggestions/ideas?
Also verified game files which all seemed fine, and have the latest grim internals version, am i missing something else?

thanks in advance

Open GrimInternals.ini with an text-editor, search for “DisableFloatingText=”
and set it to false. Then save the file.
Hope this helps!

it worked, thanks alot! :grinning_face_with_smiling_eyes:

1 Like

Hey there, i just discovered this awesome tool of yours!

While i haven’t spendt much time exploring the config-window yet, i’m struggeling to configure each monster types settings seperately. When i change any settings concerning healthbars, then switch to another monster type, it will have the same changes applied.

So basically i’d like to have boss mobs more highlighted from the rest, and have trashmobs more in the background, but not completely disabled ^^

Maybe you can direct me on where i’m failing.
Thanks in advance, and thanks a lot for your work in general!

1 Like

Welcome to the forum! :slight_smile:

You can’t configure the health bars for each monster type separately.
The drop-down menu, where you can choose between “Common Monster +”, “Champion Monster +” etc., only determines for which types the health bars should be displayed; it’s a bit misleading, I know!

What you can do for each monster type is changing the health bar colors and size.
I recommend to take a look in the Q&A.

My english is shit af, so here watch this video. Cant use my modded character on the crucible, works fine on campaign.

Welcome to the forum. :slightly_smiling_face:

Did you use the special command line to make it possible to play modded characters in Crucible?