[Tool] Grim Internals

So, the usual ETA? 1-3 days?

Hours, usually.
She´s pretty fast. :wink:

Kind of mad how useful GI is. Hope it’ll become a core functionality at some point. Might even help the console players more than PC. But still, great work as always! <3

I’ll update GI once the GOG version of Grim Dawn is out too;
so hopefully this evening or tomorrow evening (EST Time Zone).

5 Likes

Most of the important features (health bars, auto loot, selectable Crucible map, …) are already incorporated into Grim Dawn since v1.1.4.0. :slight_smile:

Grim Internals (x64) v1.106 for GD Patch v1.1.9.6 2022-06-20T22:00:00Z
Download-Link (MEGA)
Download-Link (Google Drive)

Known issue:

18 Likes

I’ve been playing at 1,8x speed for a week or so now. When booting up the game without grim internals I SWEAR it’s going in slow motion. Is it possible that Grim Internals in some funky way has set the base speed of GD to be slower than it used to be, or am I just totally misremembering how molasses-like the game actually is?

I have a problem with GOG version 1.1.9.6 and GI 1.106 - the info box is no longer shown in-game. Opening the config window with CTRL+F5 works as expected.

The info box DOES show up after alt-tabbing out of GD and tabbing back in, but it does not update the kill counter subsequently (for example, if I killed an enemy without the info box showing, it will show a kill count of 1 after tabbing out and back into the game. If i then kill another enemy, it won’t update the kill count to 2).

The same setup worked fine with GD 1.1.9.5 and GI 1.105 until a couple of hours ago.

Does anybody else have the same issue or I am doing something wrong?

And thanks for your awesome work!

My guess is that you probably forgot to copy over the file GrimInternalsDLL64.dll from the archive. Check the GI files.

Thanks for your quick answer :slightly_smiling_face:

So, I just checked:
I deleted the files GrimInternals64.exe, GrimInternalsDll64.dll, GrimInternals.ini and GrimInternals_TeleportList.txt and the folder _GrimInternalsData from my game directory (C:\Program Files (x86)\GOG Galaxy\Games\Grim Dawn), unzipped the archive, “unblocked” both *.dll and *.exe in the Explorer file properties (in case this makes any difference when I run GrimInternals64.exe directly from Explorer) and copied all files/folders from the archive into my game directory.

GD starts just fine, and the GI health bars work fine as well. But the info box UI is not showing up initially. Tabbing in and out works, and some playing around with SHIFT+F1 gets it to show up as well, but kill + item counter and incoming dps meter do not seem to update at all. I do get the impression that once the info box is shown, it is no longer updated at all.

Internally all values seem to be updated correctly, though - I do get the right/most recent numbers after disabling + enabling the info box again.

I’ve tried downpatching to 1.1.9.5 in GOG Galaxy and reinstalling GI 1.105 (which I had still saved, I bought Grim Dawn a couple of days ago) - this works fine as before. Completely uninstalling GD and reinstalling 1.1.9.6 from scratch via GOG Galaxy does not help either.

But since no other GOG users are reporting issues I’m sure it must be a problem on my end.

That’s a weird problem then! I’ll double check GI when I get back from the office.

In the meantime…anyone here who is using GI with the GOG version of Grim Dawn v1.1.9.6 and can confirm that GI is working fine?

I’ve noticed yesterday when playing without GI, that I seem to have some random stutter. I can’t really explain why it happens, but it seems to happen only with GI. I have most of the text features disabled. I only have the buff duration, nameplates, and item auto pickup. Any tips?
Edit: I play on steam, and launch through Wanez Tool for Grim Dawn.

heya GG ! weird thing is that the exe and the dll file does not extract and disappears once I extract from the zip file. only the grim internals data folder is extracted.

Dobry day! Thanks for your work and quick update. I have a problem on an ongoing basis. She was before, but rarely and was solved by re-entering the teleport. Now, when choosing any teleport from those saved in the list, the character, when moving to the desired location, stands still and cannot move ((

Fast and reliable as always
Thanks Glockio :]

1 Like

Hello. I did some minor testing with GOG version of GD (1.1.9.6x64) and GI (v1.106) and ran into a problem. The character would become unable to move after the Ctrl+f5 window is closed. This doesn’t happen at 100% rate but close. You don’t need to change any of the Ctrl+f5 windows settings to become stuck. Getting unstuck is inconsistent and is done by changing the Ctrl+f5 windows settings. After further testing I noticed that these issues only happen when the game is running in any of the windowed modes. However, while the Fullscreen is on, the Ctrl+f5 window sometimes minimizes the game, and sometimes appears on top of it like it should.

Is the info box visible on the left side of the screen and is it functional?
(I’m asking because of a problem another user have).

I can’t reproduce this issue in the short time I was testing… :confused:
I play only in windowed mode and that the character become unable to move while the Configurator window is open; that is intended. You have to close the Configurator window.

Do you play in full screen mode? Is the Configurator window closed when you try to move your char?

Your Antivirus software is deleting my tool. Consider to add GI to the AV’s whitelist.

The infobox kill and item counters work, and can be turned on and off without issues that I know of.

1 Like