[Tool] Rainbow Filter (Item Highlighting)

@Jia_Hao - I moved your post into the relevant thread - go to the top for directions.

Hello lovely people - do I need to update the Item Filter mod because of the release of :smiley:

Yes, you do. Take a look.

1 Like

You will get Tag not found for new tags. It won’t break the game though.

Matougi has uploaded the new files already, so you are in luck.

the tool should work as is, just need to start it and Save Colors.

1 Like

Excellent info - cheers both! :slight_smile:

Tool has been updated to v0.3.0

GitHub Releases - if you have the tool already, its auto-updater should take care of it.

  • New: Added native support for Grim Dawn v1.1.3.0 Items.
    • New sets are being recognized as such.
  • New: Deletion of ColorCoding files.
    • This is useful if you do not want to use ColorCoding or when you save a different color preset. (not every preset will use the same files, so overwriting them won’t be enough to remove certain color changes)
    • A new button was added to Settings that will delete ColorCoding files for non-localization.
    • A new checkbox was added (Auto-Delete Old Files) to Settings, this will delete old ColorCoding files automatically when you use Save Colors. (disabled by default)
  • New: Added information to close Grim Dawn if path could not be found. (this does not change how the tool works)
  • New: Library now remembers your last used Color Preset.
  • Removed: Removed Settings-Button (gear icon in the top right), as it added no functionality and was a remainder from the old tools. The only settings of importance are accessible from the left-hand side menu.
  • Improvement: Various UI & information text improvements.
    • Tag-Adder in Settings, no functionality changes - only UI and in-tool information.
    • Library updated in the same way.
  • Bug Fix: Fixed an issue with optional User Data Path, where the path required /Settings at the end. If it worked for you, nothing you need to change, the tool will check if /Settings is at the end of the path and add it if not.

New Color Preset: Diablo & PoE

Start Download v1.1.3.0 or go to my GitHub releases page, it is an attachment for v0.3.0.
Note: Sets don’t have the prefixed (S) Symbol, they have a different color.

  • Common
  • Magic
  • Rare | MI - Rare
  • Epic | MI - Epic
  • Legendary | MI - Legendary
  • Set (Epic/Legendary) | MI - Set (Epic/Legendary)
  • Properties are the same as with Full Rainbow.

First Post has been updated to reflect changes and a warning for outdated mod versions.


Thank you for the update and the news. I fixed the mistakes of the final version. :sweat_smile:

1 Like

Hi, this looks like a great addition to the game, thanks for your effort! One question - just installed v0.3.0 and I’m not finding a UI element to set the path to Grim Dawn? Running Win 10 with the latest updates. Am I missing something?

You should be seeing this:

try restarting the tool or reload with F5

Didn’t work, even after I restarted to make sure there aren’t any relevant processes in the background:

Not sure how you got out of the Filter content, unless user data is deleted or wasn’t saved in the first place it’s not possible.

You could try starting it as admin, there should never be an issue writing into user folders in windows, but it’s the only thing I can think of.

And keep clicking on Settings, lol, I cannot reproduce this unless I delete my user data in C:\Users\Ware\AppData\Roaming\wanezgdtools

Odd indeed, the C:\Users[user]\AppData\Roaming\wanezgdtools folder is there, running as admin doesn’t help. Neither does re-installing the tool. I’ll keep you posted = ]

1 Like

Hi, I use Win 7 64 Bit

same here, cant open the settings page, play with german localisation, so it worked up to 2.2 pretty well, with version 3 after automatically update there is no settings page, so the button save colors wont work…

1 Like

Tool - v0.3.1 - Settings Hotfix

  • Bug Fix: Fixed an issue preventing to load Settings

I added a Module/Class pack I was working on for my (private) modding tools and it was using a total path for something not even used for this, so this is why it was fine for me and not loading properly for everyone else. Let me know if it is fixed. Sorry about that :sweat:


Thanks for the quick fix. Just now, I was wondering because the Settings tab didn’t open when trying to set Diablo’s color settings for translation.

Now the tools are properly available and enjoying the colors of Diablo. :smile:

1 Like

Did some French who did the localization of this wonderful mod ?

Tested now…all colors works…thank you :wink:

1 Like

Thank you for the effort to update for the latest update

That’s quite an amazing addition, though i’ve to add while i tried it out, it kinda confused me due the Item-Color of the Pictures doesn’t reflect the font color. Not a critique by the way! But the Tools is still amazing and it’s really easy to use, you don’t need to wait for someone to update the zipfile etc.

1 Like

I totally agree with this. The leading role who has been absent has returned and my role has already ended.

However, the demand for finished version is still high. From the next, WareBare, you should put the finished version of the Diablo color and the Rainbow on the OP. :slightly_smiling_face:

1 Like