Ulgrim won't talk to me in Deadman's Gulch

I skiped him when I arrived to Gulch and went straight for Homestead. Now when I go back to him he just have the green triangle above his head doesnt give me the option to take the quest. So he never will be Homestead so my quest line is stuck. Or is there workaround?
This is on normal difficuilty.

Have you tried verifying your game files?

Pretty sure I skipped talking to Ulgrim/getting the Homestead breadcrumbs quest at one point until I cleared the Homestead rift with no issue.

Yes I have tried that. It’s first time for me too. I will try to complete the Dermapteran quest line and maybe something will happen. But don’t know.

First of all: Welcome to the forums!

Bezrayer1, did you try to talk to captain Somer (the Black Legion officer)? And if so, did she give you the quest to kill the Aetherial Amalgamation?

This questline should be most relevant regarding Ulgrim. Since he is “needed” as quest giver in a follow-up quest (the one that makes you choose Kymon or Death’s Vigil), working for Cpt. Somer might bring him to Homestead.