Unable to extract GDX2 world001.map

Hey folks, I have a problem. I’m unable to extract the gdx2 world001.map (from gdx2 Levels.arc). Whenever I try, it causes the Archive Tool to stop working and the resultant world001.map file is only 0KB in size. This means I’m unable to play the Forgotten Gods expansion through my custom mod.

I have successfully extracted the GDX1 world001.map (converted it to a .wrl) and disabled all environmental damage. So I have the AoM content.

But I’ve just defeated the Warden and there is no NPC to take me to the Forgotten Gods content. So clearly, I don’t have that content in my mod.

Ideally, I’d really like to be able to extract the FG map. But if that isn’t possible, does anybody know of a workaround? Would copying the (unextracted) gdx2 folder from the game’s installation folder to my mod folder work?

How can I make my mod recognize and play the Forgotten Gods content now that I’m using a modified world001.map?

The problem here is that the maps of gd and gdx1 aren’t used at all if you have forgotten gods. The forgotten gods map includes the two former maps and is the only one used by the game.

So if you really wanted to add the fg content you’d have to port over all the maps, quests, entity groups, region layers etc.

As for unpacking the levels file, i also get an error:

So this seems to be something only the devs can fix (or maybe some skilled reverse engineer…)

Yes, I was thinking that might work. But I’m not quite sure how to do it. As I can’t port any of the (extracted) FG maps, I was hoping that if I copied the content from the (unextracted) gdx2 folder to my mod, that it might work.

So I tried copying all the .arc files to my mod’s resources folder and the GDX2.arz to my database folder. But I’m afraid that didn’t work.

So it looks like it’s not possible to play the Forgotten Gods content if you modify the world map :frowning:

The only tool that is able to extract the gdx2 levels.arc file is grimarc.

grimarc.zip (10.9 KB)

Thank you so much GlockenGerda.

I’ve followed the instructions and it seems to have worked. But I can’t find the ‘extracted’ folder.

Do you have any idea where it might be? Thanks again.

Edit: Never mind, I found it. It put in in my System © drive :smiley:

Oh I’m so close to getting this working. But I’ve hit a snag.

When I used GrimArc I ended up with a mainmenu folder and a world001.map :+1:

I then used MapDecomp to create a world001.wrl and a world001.sd. But it also created a folder called Sandbox which contains .lvl files.

I wasn’t sure where to put the mainmenu and Sandbox folders so this is what I did:

Copied world001.wrl and world001.sd to \Grim Dawn\mods…yourmod_folder\source\maps.
The level files to \Grim Dawn\mods…yourmod_folder\source\levels.
The mainmenu file to \Grim Dawn\mods…yourmod_folder\source\levels.
The sandbox file to \Grim Dawn\mods…yourmod_folder\source\levels.

But when I try to build my mod, I get the following error:

I suspect I’ve copied something to the wrong location. Does anybody know what I’ve done wrong?

The red error text said it : The sandbox levels should be placed under \Grim Dawn\mods…yourmod_folder\source\sandbox :slight_smile:

One last hint:
If you copy the created world from \Grim Dawn\mods…yourmod_folder\resources\maps\world001.map
to your \Grim Dawn\Settings folder (if there is no settings folder, create it)
then the game uses your newly created world in the main campaign!

Have fun with your world!

Yes! Yes! Yes! That did the trick!

The Emissary is now in Devil’s Crossing. Thank you so much GlockenGerda.

And thank you for the tip :smiley:

Bummer! Everything was fine, I’ve been running around having a blast. But I’ve just realized, I don’t have any riftgates marked on the FG map:

The riftgates themselves exist in the world, they just don’t show on my World Map (they do show on the Local Map). The rest of the world’s riftgates are marked on the map, just not the FG ones.

Edit: I tried copying the riftgatemap folder from the extracted gdx2 ui folder to my mod’s ui/riftgatemap folder, but unfortunately that didn’t work. I’m a bit baffled, I’m not quite sure what I should try next.

The screenshot looks normal to me and Port Valbury isn’t part of FG.
Show us the FG world map (Korvan Basin).

So that section of the map isn’t part of FG?

I’ve scrolled all over and the only thing I see is a bordered section of map called Korvan Basin on the far right side. Is this the right map?

Unfortunately, it doesn’t seem to have any Riftgates either. So I think I might start over from scratch to see if I can track down what I’ve done wrong.

Quick question, do I actually need the mainmenu folder? Cause I’m not sure where to put it. So I’m thinking I’ll make a brand new clean mod and just copy the world001.wrl, world001.sd, the Levels and the Sandbox files to it.

Yes, that whole area in the border is FG content. It all takes place there.

Aha! Well, at least now I know where to look :smiley:

No, you don’t need it for your purpose. It’s just the mainmenu level (the background you can see in the character selection screen).

Good idea and good luck! :slight_smile:

Yep, it was something in my original mod that was causing the problem. I’ve just made a brand new mod with nothing but the world001 files, Levels and Sandbox in it.

Guess what? I now have Riftgates in the FG map! :smiley:

I haven’t copied the mainmenu folder, but ‘touchwood’ it seems to be working without it.

Now I need to slowly add all my modded files to see which one breaks it.