[0.9.2] After barracks upgrade can't hire more than 12 units

Clear game after 0.9.2 upgrade, all old saves is deleted.
Basic barracks is 12 units limit, but after upgrade 12/24 still maximum with any positions.
I already try to remove all units and hire them again, but 12/24 is maximum for no reason.

Did you verify the game files?

No, it was fixed after save/load. But for some reason it was bugged.

I still have this bug too. Was in the playtest, still persists. This is on the same map I played during the playtest though. Edit: yup, save/load fixes it for me too.

Same issue. Fired all soldiers, tried rehiring, it allows a mix of 24 to be chosen, but you only seem to get the first 12. So stuck at 12 units with upgraded garrison. On new game v9.2

We are looking for steps to reproduce this issue. So far we’ve had no luck getting it to occur.

Yes, I also found this “bug” in my old save file yesterday, the limit is 12 not 24 for tier 2 barracks.

Happened to me yesterday in this way:

  1. built a new barrack;
  2. transfered 12 archers from another barrack I had to the new one;
  3. upgraded the new barrack to fort;
  4. tried to recuit another 2 archers (12+2) in the new fort but they stay at 12 and new ones are not recruited

Game was a new one after 0.9.2 full release.

Hope it helps!

This should be resolved with v0.9.2b, you repro’d the issue in that version?

When 0.9.2b was released? I think it was on 0.9.2a but I’m not sure…