[] Random crashes on PC


Ever since I built a new PC last November, GD has started crashing randomly during gameplay (not in menus so far). I’ve had crashes from within minutes of starting a session to over 5 hours after starting, both in and out of combat. Areas I’ve had crashes in included Devil’s Crossing, Underground Transit, the fort in Tyrant’s Hold and parts of Ugdenbog, and it has happened on a variety of characters.

There seems to be no pattern to it and no steps to reproduce it. It can happen multiple times a day or not a single time in multiple days.

My temperatures and performance are good on all other games. I run no overlays besides the Steam one, but have had crashes with it disabled too.

I’ve submitted multiple crash reports with the crash tool and have saved a few logs, which I can provide if needed. These reports are from version, but I also had crashes last time I played GD, around April this year.DxDiag.txt (85.4 KB)

Small update, after some more testing.

I’ve had crashes in the Crate Entertainment splash screen upon starting the game and during loading screens before selecting a character, and also both in 32 and 64 bit modes, and with and without the legacy DX9 renderer mode enabled.

I’ve submitted all crash reports so far, but does that help? Does anyone look into these?

What steps have you taken so far? File Verification? Driver updates? Clean My Games directory? Are you running any mods? Etc?

Thank you for the follow-up.

It happens running vanilla, without any mods. I have all DLC except the soundtrack. I often use GD Item Assistant, but the crashes happen independently of it (doesn’t matter if it’s running or not, or even if it’s uninstalled).

So far I’ve tried:
-Verifying files on Steam
-Running the repair tool in the game’s folder
-Reinstalling the game
-Reinstalling to a different drive
-Removing the options.txt file to regenerate it
-Reinstalling DirectX and every Visual Studio redist I have
-Updating SATA and LAN controller drivers between April and now (unrelated to GD crashing)
-Using /d3d9, x64 and x86 in different combinations
-Changing multiple settings in-game (fullscreen/borderless, lower refresh rate, V-Sync and triple buffering, post processing, deferred rendering, background FPS, shadows and anti-aliasing off the top of my head) and forcing V-Sync and triple buffering on/off on the Nvidia CP
-Enabling debug mode on the Nvidia CP
-Disabling Steam overlay

But nothing seems to solve it. I’ve tried all of these until a crash occurred. The only change came from disabling full screen; with full screen on, I got a black screen, while with borderless mode, the game simply freezes. The crash reporter process opens at this time, but is inaccessible until I manually end the Grim Dawn process through task manager, at which point the crash reporter window pops up.

If it matters, the game seems to behave the same way when it crashes. The visuals freeze completely (in full screen mode, it goes black instead) and the game is totally unresponsive, but I can still see and move the in-game cursor and still hear the music. Anything else I have running continues running as normal.

Next I’ll try after I update GPU drivers. But in case that doesn’t solve it, is there anything else I should try?

I would try updated drivers / VC Redistributables / DirectX and I would try wiping out the My Games folder (back it up!) for Grim Dawn to start as if you had a fresh install of the game with no saves.

I updated GPU drivers with a clean install, VR redists and DX were updated. Playing with a blank My Games folder made no difference.

I discovered something incidentally. I feel stupid for not realizing but I’d been running the Nvidia overlay for Shadowplay until reinstalling the drivers accidentally got rid of both. This allowed me to play for ~20 hours across a few sessions without any crashes.

During this time I tested with the overlay enabled, and sure enough, the first crash came within 2 hours. None without the overlay, until today.

After restoring the folder, and with the Nvidia overlay and Shadowplay both disabled, I managed to play 4-6 hours without a crash, but just now the game crashed again, same way as before. I sent the corresponding report and saved a copy in case it’s needed.

Not really fixed, I guess… what else should I try?

1 Like

I always had some black screen crashes every now and then, they were rare but they were happening (but never on main menu). However, since 2 patches ago or something, i never got a crash while playing the game BUT now i can get a black screen after Crate logo, or briefly after when i click Start. When i get these black screens, music keeps playing in background.

1 Like

I know this is a late response but Ive got exactly the same issues on 2 xboxs, although it seems exclusively with multiplayer, whoever the host is will have seemingly random crashes, sometimes minutes in, sometimes hours…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.