7950x3D Very low performance [SOLVED]

I’m wondering if other’s with this CPU have noticed this behaviour. I just installed my new 7950x3D and now Grim Dawn sees huge and constant FPS drops into the 30s and 40s.

Going by MSI afterburner it seems the game is barely using my GPU or CPU. And so far my other games are working fine. Game Mode is on and the Xbox game bar is installed.


AMD 7950x3D (Latest chipset drivers 20/04/2023)
MSI x670E Carbon Wifi (Latest BIOS 20/04/2023)
32GB DDR5 @ 6000MHz
Aorus Master RTX 4090
Windows 10 Pro (Build 19044)

An image of my CPU and GPU behaviour in-game:

deferred render on ?
powerplan set to high performance instead of default/balanced? (don’t remember what the other amd user called it)
*made sure video settings are right, like correct gpu selected etc?

Yes, I’ve tried all of the different power plans and I get the same behaviour. Deferred render is also on.

The 7950x3D is an unusual CPU so maybe it confuses some of these older games, but I suspect something is wrong with my setup in this case.

*Yes the RTX 4090 is selected in the settings.

Don’t just select 4090 in settings. Go to BIOS instead and disable integrated GPU to make sure it’s not used. At least for a test.

I don’t see how these would be beneficial. I would get rid of both.

Did you follow AMD’s guideline on installing 7950x3d chip?

Does disabling any CCD on the chip give different redults?

The new 7900x3D and 7950x3D have two types of cores - high cache cores and high frequency cores - and they require Game mode to be enabled and the Xbox game bar installed to function. Windows uses them to identify when a game is running and allocates CPU cores accordingly.

In any case, this is now solved. I did a fresh Windows install when I upgraded to Windows 11 and performance is normal now. As I suspected there was some sote of software / driver issue on my end.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.