"A Mad Stash" Achievement mechanics question (contains spoilers for Mad Rambings quest)

Spoilers for Mad Ramblings quest ahead.

So I recently found out that some people have discovered that it’s possible to collect ALL rewards from the Mad Ramblings quest by

  1. with Ivonda’s Memory in inventory, triggering the torch to open the hidden path to the crypt entrance
  2. opening a riftgate in that hidden path (making sure not to click on the crypt entrance first) and returning to Ivonda
  3. handing in Ivonda’s Memory and completing the quest
  4. returning via that riftgate to plunder Ivonda’s Hideaway

According to the gamepedia page


there might be a small wrinkle to this approach, though, specifically “If you do not desire or already have the achievement, you can…” (same method described above). In other words, it’s suggested that the above approach won’t trigger the achievement.

My question is whether anyone can confirm whether or not the achievement is triggered when following the above steps. It seems to me that the gamepedia page may be wrong for two reasons:

  1. It seems much simpler for the achievement flag just to be entry into Ivonda’s Hideaway rather than entry PLUS either Ivonda’s Memory in inventory or Mad Ramblings quest currently in progress
  2. game wikis are routinely missing information, so while it’s entirely plausible that someone took the above steps, failed to get the achievement, and suggested as much in the gamepedia page, it’s also plausible that the person who wrote that part of the page already had the achievement and just wrote the way they did out of caution because they hadn’t tested without the achievement

Anyway, I hope you’ll excuse the wall of text over a totally unimportant curiosity.

This works now? Tried it 3 patches ago and just didn’t work.

Not sure. I haven’t actually got around to trying it myself yet. I had just heard about it from multiple places, so I assumed the info was current. If it didn’t work for you, then it might also be possible that it worked at one point and got patched out or something.

What part of the process failed for you? It seems like as long as you don’t make your riftgate in the crypt/hideaway itself, everything should be fine unless you’re somehow prevented from either (a) creating the riftgate in the necessary spot or (b) warping back to the riftgate you created.

Edit: I guess one could also cause the maneuver to fail by disabling interaction with the crypt entrance when the quest is inactive as well.

Got the scripts in my stash, went to the dungeon. Touching the torch didnt do a thing.

I’m confused here. The torch part should be normal quest progression where rather than returning Ivonda’s Memory to her right away, you instead go to trigger the torch. There should be no issue with this part. That being said, there was an issue with this quest in the past that was patched out (see the patch note on Mad Ramblings quest):

Or maybe I’m misunderstanding your post. Did you try this just now by GD Stashing in the quest item? If so, it’s possible that the torch interaction could fail if you don’t have the quest active.

Strange, it always work for me. After getting the note activate the torch and go to the opened room but dont enter it yet, portal back to Ivonda and give her note and wait for a while (I’m walking to sewer and out to steelcap district back and forth until Ivonda chest appear), get the reward from ivonda chest and go back to the tomb portal and enter the ivonda room to loot.

ah, … one time i got a reward chest from ivonda. Without going anywhere. Was wondering why theres been no chest there since.
What if i enter the room too early…?
Anyway, gonna give it a re-try.

jeah been there now.
found the torch. touched it . nothing happens.
delivering the notes to the lady, the torch is not even touchable anymore.

I haven’t found much time to play lately, so I still haven’t got around to testing myself, but this video

has an example of how to do the trick. (See 1:11:25 for what to do once you have Ivonda’s Memory in your possession.)

So I finally got around to testing this myself. As the gamepedia page seems to suggest, doing this trick does NOT trigger the “A Mad Stash” achievement. This is surprising to me since it demonstrates that the achievement flag is tied to the quest itself, not just entry into the crypt, which is odd, since all the achievement description says is “Raid Ivonda’s Hidden Stash,” which you certainly do when employing this trick. Oh well, now I know for sure. :man_shrugging:

You guys would rob a poor sick woman?



Must. Obtain. Loot.

Isn’t it fitting, though, that the one time you can play both sides of a quest, it’s with the NPC that won’t remember anyway?

1 Like