bluetooth (widcomm/broadcom) uninstall help!

Hey guys,

I’ve been using a bluetooth headset on my pc for the past year or so using a third party dongle, and all has been well. However when I updated to Windows 10 from Win7 about a month ago, it started having problems connecting. I tried to install a newer driver, but it wouldn’t go, it says I have to uninstall the older version.

So, I went into windows add/remove utility, ran the uninstaller. It had an error, but proceeded to finish the uninstall process and removed itself from the list of programs to uninstall. Tried to install the new driver… same issue, gotta uninstall the old version still. I’ve looked in the folder where it was installed, forcibly deleted it, deleted anything even remotely close to widcomm/broadcom) looked in the registry, removed some entries specifically pointing to widcomm/broadcom and removed them.

Still the same issue. No idea where to look now. Suggestions welcome! I’m thinking of just reinstalling windows completely as it has been a while since I have done so, but the thought of backing up all this stuff and going through it makes me cringe.

I had a similar issue with an AMD driver awhile back. The only thing that worked for me was getting the Official AMD driver uninstaller off the site. So maybe if your lucky the manufacture site may have something that can uninstall the driver properly, allowing you to install the new Driver correctly.

Try reinstalling the old one that failed to completely uninstall and then uninstall in safe mode…if win10 still has safe mode.

It does. Just like “truly” shutting down Win 10 ( holding down shift while clicking shut down) you have to hold shift while clicking restart. Well, at lest that works for me.

Also did you try the uninstall driver option in device manager?

Yes I did. No luck.

Here is the error I get when I try to install the driver for my bluetooth usb stick.

It does not show up in the list of programs, so I cannot uninstall it. :confused:

Humm, so even if you reinstall the old driver, it still wont show up in the programs list?

I have to say this is quite odd.

Well first of all, I don’t know exactly which driver is the old driver. (there’s no trace on this pc anymore from what I can tell)

But, like I said in the OP, I’m on win10 now and the driver was installed on windows 7. I went to the website where I think I probably got the driver, tried the win 7 drivers, don’t work at all, compatability issues and all, not that I expected them to but whatever. The win10 driver gives me the error I posted above.

I’m apparently not alone in this, I have seen quite a few people posting about this, but I have had no luck getting to the bottom of it. Device Manager, program remover, etc, nothing. I have NO clue what is preventing this from installing.

Damn that sucks man. The only thing i can think of is to factory reset your PC and install the new drivers but, if other people are having this issue than it is not guaranteed that anything will work. :undecided:

Wish i had more informational input on this situation. :o

Did you try driver sweeper?


It says it was replaced by “Display Driver Sweeper”, which is not my issue.

The problem could be caused by the special folder used by the installshield not being deleted during uninstallation.

To find out, check the contents of the folders in the “Installshield installation Information” folder. You will have to unhide hidden files and folders and make sure you can see the file type names. You can do that in the settings in Windows Explorer.

Using Notepad or Notepadd++ to open the Setup.ini file and look at the line “AppName=”. When you find the one with the name of the software for your Bluetooth dongle, rename the folder with the strange name it resides in by adding aaaa at the start of the folder name. If you simply delete the folder and it is not the correct one you will be unable to uninstall some program or driver.

If renaming the folder allows you to install the new driver, then it should be okay to delete the renamed folder - or simply leave it as is, it does not harm anything having there.

I checked all of these folders (there’s about 10 or so), and looked at the .ini in each one, none of them seem to be the bluetooth. I have a ton of Sims3 and printer related files.

Have you tried opening Device Manager and update the driver software letting Windows seach online? Sometimes that does the trick.

As there is nothing in the Installshield Installation Information folder the problem is likely in the Registry. Not a place to fool around as what is deleted is deleted unless one takes a backup first and in worst case is able to use that backup if it goes horribly wrong.

@PCDania, yes I did try all that, but thankfully I did find a fix by using the “Reset” feature in Windows10 to ‘reinstall’ windows. Worked like a charm.

Great you found a solution to the problem :slight_smile: