Cannot set crops on any fields

Newest version causes my farm UI to not become visible on both old save games and new towns. I click the farm, it makes the sound it normally does but the menu does not come up that allows me to set my crop rotation. very frustrating because it makes it so much harder to advance my village

Did you verify game files? Do you have any UI scaling set?

I apologize, I’m not very good with computers. I am playing 100% vanilla and haven’t changed any settings. Not sure if i hit some shortcut key maybe or if its actually a glitcb

Update on this: it seems to be with fields that are not max size: 12x24 squares. When a new field is completed i have exactly one shot to set the field for what i want. If i click out of the field menu it will not come back up again. So i have had to build my fields as large as can be constructed (12x12) and then when they are complete i have to immediately set its crop rotation and then lay out the other 12x12 plot from the expand field button. If you do it the opposite order and expand the field first it will not let you go back in and set the crop rotation

Try these steps for verifying game files:

  1. Right click Farthest Frontier in your Library and choose “Properties”.
  2. Select the “Local Files” tab.
  3. Press the “Verify Integrity of Game Cache” button.
  4. Steam will redownload the missing files.

If that does not help. Please go to your game Settings. Under Video, let me know what the resolution is set to. Under Interface, what the UI Scale is set to.

Hello, I have the same problem. I created a field, selected primary crops, closed the menu and can no longer open it, when I click on the field, it only makes a sound.

The issue here is with accessing building menu when the building is in progress with either moving for most building and field expansion for farming. Once the building in progress is completed you will have access to it’s building menu again.

I’ve experience this with both the trading post, moving to new location, and all farming fields when I expand the field. In both cases, once the trading post was moved, I was able to access the trading menu, and once the farming field finishes the expansion work, I was able to open the faming menu again and adjust their rotations.

I think this issue is related to accessing these menus during these “inaccessible” times.

Negative, that’s not my issue, this happens when the farm is complete and is not 12x24 squares in size. I have to build it at 12x12, wait for it to complete, then i have 1 shot to tell my villagers what i want planted and then expand the field to maximum size of 12x24. I verified my files on steam like i was suggested but not yet had a chance to see if it worked as i am at work until next Wednesday.

You have exactly stated what I also experienced.

I built my initial field first (typically 6x12), once finished, set my initial rotation. Then when i expand my field to 12x12, I would no longer be able to access the farming menu. Once the expansion of the field completes, I would then be able to access the field planting menu again. When I expand that 12x12 field to 12x24, during that expansion timeframe, I would no longer be able to modify/access the crop rotation menu until the field expansion finished.

As stated, during the expansion process, you are NOT able to access/modify the crop rotation while the field is still being expanded (both during the clearing of the field and during the tilling of the field).

Once the field is fully completed would the crop rotation menu be accessible again.

This is most likely a bug as this was not how this process performed in prior patches/releases.

No, my issue is not during the field expansion. As soon as the field is finished being built I am able to open the field UI exactly once, and only when its at 12x12. If I build a smaller field i cannot open it at all ever, i just get the notification and widget that a field is missing crop rotations. What I am saying is if I want to be able to keep accessing that field’s UI I have to immediately set up the expansion to 12x24, otherwise I am not able to open the UI again, I only get the sound effect.

Did you verify game files as I suggested?

Can you share a screenshot of the issue?

I did the file verification last week but I have not had an opportunity to test it since as i am on shift until Wednesday. I will let you know when I am off shift. Screenshotting wont show you anything though

Hello, I gave it a quick test this morning and it appears so far that file verification worked. I will revisit this topic if it happens again. Thank you for your suggestion

Hi, me again. I had a PC glitch that caused my Windows to be corrupted and had to be reinstalled, which meant my files were all saved but all the games/programs I had installed were wiped. I of course reinstalled Farthest right away, started a new community, and my farm is now doing a combination of my previous issue as well as the one that was described by wrathofvi regarding the farm UI not being accessible once the field expansion is ordered. I did my best to screenshot the issue for Zantai, hope it helps.

The UI being inaccessible during expansion is correct. The field is under construction.

You are not seeing the UI when a field is finished?

It’s been hit or miss. With some fields i have the issue of only being able to open the UI once after the field is completed. If i open it that first time and then close it, it will not open again, just like in my screenshot except without having a field expansion being queued up. That’s why I say I have one chance to set my crop rotation and tell it to expand to full size, because if I don’t do it that time I never can again

And now that I have it at full size I am able to open the UI again.

What happens if you select on of the crops in the rotation?

Once it is full sized? It functions normally, i can change my crop rotations as much as i want, adjust my soil’s clay/sand ratios, destroy the field if i so choose, etc. I wanted to ask though, it’s normal to be unable to access the finished part of my field’s UI while there is a crop expansion queued or in progress? Seems strange to be unable to access it when the farmers still farm it like normal despite the expansion being queued or in progress

As I’ve said, yes. An expansion under construction counts as the field being under construction. This is normal.

1 Like