Can't open DBReditor or files

I’m running Windows 10 and can’t seem to open the .dbr files to even begin understanding how modding works.

Opening the DBReditor asks to install .net 3.5 framework, but I have 4.5/4.6 by default (which should include older packages I thought), but nothing actually opens when DBRe tries to install 3.5, nor can I get that package to independently install via

Anyone having similar issues and figured out how to fix?

Have you tried opening a DBR from the asset manager?
Also, if you have .net 4.5, DOES NOT mean that you have .net 3.5, they are different frameworks. You may try installing it manually from here:

Even if you download it from the link above?

Yeah tried to install it directly from microsoft, doesn’t seem to even load the file for whatever reason. IDK anything about the dbr extension but I just tried opening it in Sublime and it’s readable there. shrug

I can give you .net 3.5 setup file (the one from the link) if you are not able to download it.

DBR is a basic text file, and the interface inherits some default values from the TPL files. I use and recommend DBR Editor, but a lot of people just use their favorite text editor. Sometimes I just use my text editor, but I like the “Description” and side by side comparison of the columns.

If you double click a dbr file from within the Asset Manager, and OLE call is made to load the DBR Editor. I recommend just double clicking the DBR Editor directly for troubleshooting purposes.

PrincessLuna is totally correct, NET 3.5 and 4.5 are completely separate installations. There is minimal backward or forward compatibility, you need to have a separate installation for some versions in use. (3.0 uses 3.5, but 4.0, 4.5, etc are separate installs.)

Here are a few different installation methods for 3.5 on Windows 10:
(Add/remove features)

(Separate download)

(Windows in-‘capabilities’ )

(Command line)

DISM.EXE /Online /Add-Package /PackagePath:C:\Features\