Can't switch weapons

I’ve seen Google references to this bug going back at least six years.

I have a weapon, and a weapon on swap. I never use the weapon that’s on swap. I’d just been in combat, I died a couple of times, but finally I won, and stuff dropped. The fight was the final boss in ultimate in the vanilla game, but I do have all expansion and DLC installed. I wanted to see if a weapon that dropped was better than the one I had on swap.

I pressed the weapon swap button on the “I” page. The button changes appearance when it’s clicked but nothing happens, the weapons don’t swap. I remove the weapon I had equipped and tried again. I put the weapon back and tried again. I changed the hot key for weapon swap (I had removed this hot key option) and pressed that key.

None of this worked. I restarted the game and it worked perfectly.

This is a generic Windows PC and there are no mods.

:rofl:Your question is so funny, you haven’t figured it out for six years?

My English is not good, I can’t explain it to you clearly. Sorry!


It’s like this’ switching '. OK?

Additionally, the default weapon exchange hotkey is “W”.

1 Like

either it’s what tt300 suggests
or you didn’t enable weapon swap by pressing the swap button in the mannequin first

if this isn’t pressed, weapon swap wont happen for the first time even if you press the hotkey,
it’s a “failsafe” feature so people stopped accidentally weapon swapping and complaining about their weapons “disappearing” :sweat_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.