Fixing lag spikes/stuttering

Hello all

Having done a bit of searching, it looks as though Grim Dawn is notorious for stuttering/micro-stuttering.

I was originally having a bad micro-stutter problem whenever moving about the map, and it was basically unlinked to FPS. I read to enable “dynamic v sync” in the nVidia control panel. I did that and viola! micro stutter is gone.

However, in the place of the awful repetitive micro-stutter emerged a more random but still reliable lag spike/stutter problem.

It basically happens whenever I am running about the map and again, appears unconnected to my FPS. It feels as though whenever the map is trying to create new frames it has to “stutter” and you feel a kind of lag/drag back effect. I don’t know if this still has something to do with vysnc, but it is absolutely infuriating.

The only other observation is that it tends to do it more when rotating the map. Also, Devil’s Crossing seems to have a unique problem - whenever I enter the prison through the main gate, vync really visibly messes up and you see a lot of vsync lines when entering and leaving. It’s the only place that does this so badly.

Any thoughts on this would be a great help, thanks.

What do you have AA set at? And the lighting option? If you have them maxed try setting AA at 4x instead and set lighting a bit lower.

There are some improvements being worked on by Crate right now that may ease the impact of these settings. No time frame on how long that will be at the moment tho.

Also, setting Vsync to adaptive may help some.

I don’t know what you mean by Vsync lines tho. There isn’t such a thing. Screen tearing is usually something that happens when Vsync is not present.

With Vsync enabled you will instead get frame drops that cause stuttering when the frame rate shifts from the monitors refresh rate. Which is where the adaptive setting comes in and helps some.

Sent from my SCH-I605 using Tapatalk

Settings look like this:

Bear in mind I was actually running it with no AA or anisotropic filtering for some time (at some point I hit “default” and it turned those off without me realizing it, so I normally run it at 2x, 8x respectively). But the problem was still there, though I’m not sure if to a less degree.

I have dynamic vsync switched on in nvidia console, which seemed to correct the microstutter, but I still get the big stutter/dragbacks when running around map.

As for the lines, it looks like just that - huge refresh lines running up and down the screen in Devil’s Crossing, especially when I go in and out the main gate to where the storage NPC etc is.

I see your problem. You left Vsync enabled in the in-game settings which is likely over-riding and/or conflicting with the Nvidia setting. Disable this setting in-game. Also, consider setting the Vsync in the Nvidia CP to Adaptive and see if that helps some.

Sent from my SCH-I605 using Tapatalk

Aha! That’s done the trick, thank you.

I still get the odd stutter, and there are still some areas where the vsync goes funny, but it’s much improved, and much more playable.