GD Defiler not saving characters

Hi! I recently downloaded GD Defiler and installed it. I was able to access my characters and change them, but when I went back in again and tried it a second time none of the changes would save, even though I hit the save icon. I tried saving and refreshing, and the changes were gone. I then tried to set the path in the settings to my user save directory, and then the game directory, and both times it wouldn’t accept the path and gave me an error. I uninstalled and changed it back, and then tried modifying my character, and still the changes won’t stick. I feel stupid, but when you save something isn’t it supposed to save? It obviously isn’t saving in the directory, but since I cannot put a directory path for the Grim Dawn bc it gives me an error every time, Idk what to do at this point.

Oh, and I have cloud saves disabled both with the game and Steam.

I’ve been using this program. I think it didn’t save for me a couple times when I didn’t exit the game beforehand - although switching to a different character in Main Menu should be fine too. My path is empty yet the program works anyway:

Welcome to the forum. :slightly_smiling_face:

GDDefiler is years out of date now. If you want to make changes to your characters probably better to use GDStash’s editing features.

Ty medea, but I don’t need to use GDStash. Mainly I wanted to change the Masteries on my characters. I checked the description on GDStash and it doesn’t mention it can do that - it just allows for inventory management and transfer of items. Did I misread something?

Apologies - I see that it can. Hopefully, this will be much better. Ty for the help medea!

Ty tqFan - I realized that I have not been using GD Defiler while Grim Dawn was open. Maybe that was the issue? I’ll try again.

1 Like

Characater editor window.

Make a back up of the character before you change anything just in case.