Grim Dawn, But Skills Have 69 Projectiles ( Sort Of )

Player skill have extra projectiles/fragments added to them whereever possible. Some skills have their duration extended.

** Projectile on some skills scale with level and can start off at 0 **

demo: 69projectile aegis - YouTube

Changed Skills:

Soldier: Markovian’s Advantage, Zolhan’s Technique, Fighting Form
Demolitionist: Demon Fire, High Impact, Improved Casing, Static Strike, Heavy Ordnance, Full Spread
Occultist: Sigil of Consumption, Vile Eruption, Raven’s Storm Orb
Nightblade: Devouring Blades, Nether Edge, Blade Spirit’s Blade nova
Arcanist: Devastation, Supercharged, Shattered Star
Shaman: Storm Touched, Storm Surge, Grasping Vines, Feral Hunger, Briarthorn’s Slam
Inquisitor: Storm Spread, Bursting Round, Chilling Rounds, Rune of Kalastor, Rune of Hagarrad
Necromancer: Reaping Strike, Necrotic Edge, Ravenous Earth, Mage Skeltons’ Meteors and Fire Nova
Oathkeeper: Soulfire, Consecration, Smite, Aegis of Menhir
Components & Devotions


Almost died. :crazy_face:

Well, can’t seem to do the Tomb of Korvaak quest from Kymon in v1.1.9.7; the mod keeps freezing when I’m in the tomb and then I have to shut the PC down to get out because going to the task manager does nothing except make the screen black.

That is strange, as the mod only changes some player skills and adds a few fx for eagis. The rest is intouched.

Slight chance that verifying the game files solves it.

If that does not do, then it leaves some of the skills causing it, maybe a newly aquired devotion :thinking: or an outdated skill in the mod.

Listing the skills used will help.

Unfortunately i wont be able to look into it for at least 2 months :scream:

It’s a Purfier so Fire Strike, BWC, Flame Touched, Vindictive Flame, Ranged Expertise, Bursting Round, Chilling Rounds, Storm Spread, Deadly Aim. BWC is maxed, some points in Agonising Flames, Fire Strike the same, the rest just have one point in them.

Devotions - Throne, Eel, Tempest, Spider, 3 points in Rhowan’s Crown for the proc and have 3 points in Vulture.

Had no problems until I went into that tomb then crashed 3 times. Just doing the usual of standing still and throwing BWC while firing off Fire Strike and the game freezes. Then when I try and ctrl+alt+del to get to the task manager and click on that the screen goes black and I can hear the music. No way out of it except to turn off the PC.

Verified the game files and tried again with the same result, game froze shortly after entering the tomb. Only difference this time is when I hit the LMB mouse key for a second time it called up the window to say GD wasn’t responding and did I want to close the programme which I did.

Thanks for the update. Will check it out when possible.

I finally got arround to testing this and recreated your character from the description provided.

Sadly, no dice on replicating the crash :frowning: .
Tried it with both 2h and dw guns, with various devotion assignments, even had falcon on top for even more chaos.

Weird. I’ll have to give it another go when v1.2 is live and you’ve had a chance to see if the mod’s affected by all the changes in that patch. I’m on the patch atm and don’t want to revert back to