Grim Dawn on MAC - using WINE

Hi there,
first of all I’ve to say THANKS to @GloriousEggroll for this guide from where I took inspiration to make GD run on Mac.
I’ll follow his format for this guide.
(if is a double post please mod. to lock this thread)
so… let’s start!

  1. Getting the game to run:

*It must be a non-playonmac-prefix
simply I’ve first tried with playonmac and after all the game doesn’t start.

*Set your prefix windows version to Windows XP - This will prevent steamwebhelper.exe crashes.


  1. install Xcode from AppStore
  2. install X11 (XQuartz) from here
  3. install WineStaging from here
  4. follow the instruction to install MACPort
    (it will be useful for using winetricks)

once done enter in wine configuration for prefix “grim_dawn”

WINEPREFIX=~/.grim_dawn winecfg

–set windows version to windows xp and turn csmt on under staging tab

close the cfg window

create on desktop the file grimdawn.reg and then import to the registry:



WINEPREFIX=~/.grim_dawn wine regedit /path/to/grimdawn.reg


with MacPort script install CABextract with this command in a separate shell:

sudo port install cabextract

then use the following link to download the latest version of winetricks script.
save it to Desktop (for easier use)

in the WineStaging shell window type “cd Desktop” to change dir.
then run the command

WINEPREFIX=~/.grim_dawn sh winetricks -q d3dx9 msxml3 vcrun2015

later on I’ve also added d3dx10 (all dll) via winecfg but I’m pretty sure this is an useless action.

after this I’ve installed first Steam (in the same WINEPREFIX)
simply save the installer on the Desktop -we’ve the wine shell on Desktop- and from the wine shell run:

WINEPREFIX=~/.grim_dawn wine SteamSetup.exe

(or whatever is the correct name :stuck_out_tongue: )

then install Grim Dawn
(I’ve de-activated the overlay)
hit PLAY
let the auto-conf do his job

the game should have started now!

(in case you’ll not see the word over the buttons is the first button of the second group on the left side)
I’ve setted all to Medium
NO triple buffer
MAX RES. in Fullscreen-Windowed no frame
(then some video options could be back on High… just test)

for easier use:
with finder use the option “GoTo Folder” and navigate to “/path/to/user/.grim_dawn” then locate the Steam.exe file and make an alias to put on the desktop.

should run fine…
in case of need post reply below

(known issue till now:
minimap and map SOMETIMES will not show all areas correctly -some white rectangles-

I got steam running and Grim Dawn installed by following your instructions. The first time I launched it, it ran and i was bale to enter the game and start a game, but my characters weren’t the correct levels. Like the data hadn’t synced properly over steam the past couple days.

Now, when I try to launch the game from steam, it just says running, then nothing happens and gives me the option to ‘Play’ again. Any ideas?


Thanks man great thread:cool:

Thanks for your post.

I tried to install Grim Dawn on my macbook (it is way more powerful than my other laptop), and the fact is : Ground texture is missing.

I have these cards :
AMD Radeon R9 M370X 2048 Mo
IntelIrisPro 1536 Mo

And when going to settings, the radeon is displayed.
I also checked the Texture Art.arc file with the grim dawn build on my PC : the same.

Did you guys encountered such an issue?
Thanks !

PS: And yes, my first post, but I’m a grim dawn backer, and never had the time to play it (just 20 lvl with crappy lag in fact) because of the : "I’ll wait until I’ll have a better Windows laptop "