[GrimTools] Checklist

Ah yes, correct, thanks.

Dammitt : Look at attached file, Important quest, Normal => 5/4 , maybe the quest is still considered as important, i dont know much about coding heh :stuck_out_tongue:

There are 2 ways this could’ve happened:

  1. you’ve supplied the path to /Ultimate/quests.gdd into Normal difficulty when uploading char
  2. this isn’t a legit character


  1. no (or i don’t remember doing so, i always double check path but who knows)
  2. no, totally legit char

Well, if it happened just to me, nevermind :slight_smile:
I’ll try to delete the profile, and redo the whole thing to be sure

Edit : Same result :stuck_out_tongue:

I’ve fixed the issue with incorrect counters for quests and possibly shrines for old chars.

Hey. Great tool. I would also like to add my vote to the addition of the blueprint checklist.

Any reason why i get Error 404 - Not Found when trying to open the checklist???

It was disabled accidentally, sorry about that.

I love your checklist so much. Are u planning to update it to the latest version? There are many shrines in the new DLC. Thanks!

It’s gonna be updated in a week or two. I’m just holding off on updating world map and checklist to prevent possible spoilers.


Is grimtools down? i can not acces on the website today


^^^ This right here. There’s an “Error 500 - Internal Server Error” when trying to access any part of the grimtools.com site. :cry:



  • Updated to the latest patch which includes all FG content
  • Couple missing notes were added due to a fix with their detection on the map
  • Checklist groups (acts / game version) are collapsible now

Hi I am the guy who asked u about updating last week. Now I have accomplished all the 3 difficulties. There are so many shrines that we don’t have to check all shrines while playing. But I must thank u for ur hard and efficient work again. Many thanks!

There is smth wrong with the Tool after this update. When switching too translations you get ‘undefined’ in quest titles that gives additional skill points in AoM and FoG (vanilla is displaying OK).

Thanks for the report! It’s probably related to the new translations format, cause in here texts for quests are extracted from translations differently, probably using the old logic and I forgot to recheck this, shame on me :frowning: I’ll provide a fix tomorrow.

I tried uploading my player.gdc into the devotion checklist for the first time and am noticing that it isn’t capturing all of my restored nodes. Tool says only 5 in Act 1 Normal and none elsewhere though the character currently has 26 across multiples acts.

Edit: I created a new profile and tried the upload again but resulted in the same subset of shrines displaying as completed. However, about an hour later I noticed that the from the upload window within the tool, the timestamp on the player.gdc file didnt match the updated timestamp in the filesystem no matter how many times I hit refresh. I had to navigate out of the Steam folders and then go back in within the tool to get the file to refresh. After doing so, it successfully loaded all of the shrines.

Also note, the timestamp was only off by about 45 mins and some of the shrines had been completed days ago. However, I did go in and turn on Steam Cloud Save this morning but not entirely certain its related.

Just wanted to let you know this is resolved!

Hm, I have no idea what might be causing this. There’s no way browser picks up wrong/cached files, unless you select the wrong one, perhaps you previously were chosing the one from local storage after switching to cloud saves.

Love this. So glad you were able to get it back up and running.

Anyways, for the past 2 days whenever I try to upload my quests.gdd file for any difficulty I get an error message saying “Unable to read quests file”.

I don’t use cloud saves and am looking in the My Games\Grim Dawn directory. Not sure if it’s just me being an idiot or if something got weird with the restore.

Just wanted to report it in case it was something easy to fix on either end. Thanks again for this amazing site!

I use steamcloud saves and i get same error, shrine get updated but not the quest nor the oneshot chests, please help cause i really REALLY love your work!

Mine was working just fine up until the site switched hosting and now it is broke! :frowning: