help : why i can t select at lv 1 necromancer or inquisitor with the dlc

i m a new player, i have bought the extention Ashes of M, but i m lv 1 and i don t see the necromancer and inquisitor class in the selection of class ?

I have tried in veteran, but i don t see it too

Can u help me ?


Welcome to the forum. :slight_smile:

Do you have the base game as well? You need to own and install both.

And you can’t select any class until you hit level 2 - doesn’t take very long to reach it. Just kill a few foes outside Devil’s Crossing.

If you reach level 2 and they’re still not showing, exit the game and verify the game files.

For Steam right click on the game in your library and go down to Properties. Then choose Local Files and then Verify Integrity of Game Files.

For GOG Galaxy go to the game in your library, choose More and then Manage Installtion then Verify/Repair

He’s on Steam…

it’s just the usual shenanigans. He just needs to restart Steam or alternatively uncheck/recheck AoM in the game library to get it to install. I suppose verifying would do the trick as well but honestly just toggling the checkbox is the fastest way to resolve this issue.

thx for u reply.

I have restarted steam, uncheck ashes of M, and check it, steam has downloaded the dlc.
now it works fine