Input-related feedback and wishlist, from a Steam Deck player

Since realizing that GD has full controller support, I’ve been playing exclusively on my Steam Deck, and while the experience has been great so far, I have some points to bring up.

  • It would be greatly appreciated if Steam Input offered separate interact and hotbar 0 actions; not being able to tell the game which of the two you want to do in a given context where both could be relevant isn’t entirely the best feeling.
  • An option to adjust/disable the tween time when rotating the screen would be great for gamefeel, especially when using the right trackpad on the Deck. Not having immediate feedback on where exactly you’ve just put the camera can feel weird with mouse/mouselike controls.
  • There’s currently no way to use Evade using pure steaminput; it’s not an available action to map and you also can’t bind it to any of the hotbar slots. (The usual hack of binding the keyboard input is also unhelpful here due to how the game treats switching between keyboard and gamepad as a hard context switch.)
  • Setting a trackpad to raw mouse in steaminput (in hopes of being able to quickly mouse over and pick up specific items) doesn’t work last I checked; it just kind of rapidly flickers between gamepad and mouse HUD states and doesn’t actually let you do anything. (Holding the steam button does allow you to do so, but this feels rather clunkier than it needs to.)

dis why i think?

Having it be mappable to a hotbar slot instead of being exclusively a dedicated mapping would provide much-needed flexibility for more limited controllers, though.

1 Like

Oh, something I forgot to mention: an option for whether to use the built-in OSK or the Steam one would be great!

Also, semi-related bug: splitting a stack with your stash open has a tendency to give OSK input to the stash search bar instead.

This still doesn’t work properly today. I have just received my Steam deck and GD is working ok. Can’t moan on the performance too much. But I was also hoping to use cursor to use some spells that need to be targeted to be effective, but this glitch that every time you touch the pad it changes toolbar is still there. I even tried to remap left trackpad to mouse or cursor in hope that this glitch won’t occur on left pad, but it occurred also pointless. Left pad can’t work as cursor in game at all…

If anyone figured solution, please let me know since this would be great addition to the build possibilities on SD

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.