Mastery Name showing ?

I am sure I saw a post on this before but cannot find it now so I am hoping one of you can answer.

My custom mastery used to show the name but for some reason it now only displays a ? both on the character sheet and when selecting your character form the menu.

I haven’t changed anything in the class.txt file so I am not sure the issue.

Is it because I made my customer class ‘class24’ ?

Any feedback would be great!

Thanks :slight_smile:

bumping sorry :stuck_out_tongue:

If you renamed a folder, you need to check every files that was associated to this pathing.

You can ignore a lot of them since all you want is “displays on the character sheet and when selecting your character from the menu”.

So you should start with “UI” folder.
You will learn more if you try to figure it out by yourself than waiting for someone to find it for you :slight_smile:

Sounds like a link broke somewhere.

I have looked, and I only ask on these forums as a last resort otherwise I’d be on here constantly with a barrage of questions. FYI I Teach Global Perspectives and ICT so I’m well aware of the importance of problem-solving, sometimes however, asking is necessary.

But thank you for taking the time to help :slight_smile:

I posted this mostly because I was sure I had read a post from Zantai saying something about it being a bug and it being fixed in a patch.

Like I said, I haven’t renamed any folders, nor the files associated with it. Surely if I had, all the descriptions for my skills would also not be working, no?

It is literally the name displayed on the character sheet in game and when choosing from the character menu in game.

Does your character use dual masteries now?
You need to set a tag for each mastery combos in the tag_skill.txt

That might be it.

The only thing I can suggest as I said before, is to double check all your links. If it worked before, and now it doesn’t, it’s because somewhere along the way you changed something that broke a link somewhere.

When you say “class24” what do you mean? The tag?

This is going to sound dumb but oh well, Can I ask where and what file you link these tags…? I have the file above like in the screenshot and even renamed some class combo’s to new stuff EXP: Arcanist + Soilder = Spellblade. Looked in the UI for a place to link but I am kinda lost. Any help would be great please.

Yeah the tag.


tagSkillClassName0224=Head Hunter

I will check tonight, you’re right, I probably have changed something somewhere. I am Thinking of just rebuilding the mod folders and links and everything anyway ready for a release version. Apart from balance issues, it is almost complete. Just several more skills to add and a bit of rejigging when some skills become available.

Actually after listing the above example, I do remember Zantai stating something about the class combinations being incorrect, as in the wrong way around, 0124 should be 2401 or something of sorts. But I don’t know, cannot remember fully.

If you mean where this file is it is here;


Class24 will be your own class tag, could be class07 as that’s the modding tutorials example.

If you mean where you link the above file, it is found in several places such as;



and in the skills themselves

look for the lines


thank you very much, Got it!

Nah not at the moment, but I have set the tags like below;


tagSkillClassName0224=Head Hunter

I know it is Something silly that I done somewhere, I will find it eventually :slight_smile:

Thank you very much

I’ll use this thread because I have a “similar” problem.

All my dual-mastery names show as expected unless the one with the demolitionist counterpart.
It displays “tagnotfound tagnameclass…” and I can’t see what’s the actual tag missing because the phrase is too long.

I think the tag is “tagSkillClassName0207” but I can’t understand why it shows the missing tag since all the others work perfectly and I checked more than once if the spelling of “tagSkillClassName0207” is correct and if it’s “filled” with my custom name.

I hope someone can solve this problem.
Thanks in advance!

Edit: spelling errors

There is a typo inside the core files using the tag variable for class combo 0207+0307 until Crate releases their patch to fix it youll have to use:

More about it including dev response at:

Thanks m8!

I was like “WTH what am I actually doing wrong?”

ahhh that answers my previous question of the bug related to mastery names not showing, but not for my particular issue :stuck_out_tongue:

I have exhausted all possible avenues that I can think of and still no luck. :frowning:

have you tried using:

tagSkillClassName0270=Head Hunter
I just assume its using class slot 7
because you can change the mastery tag but you cannot change the combo tag

instead of
tagSkillClassName0224=Head Hunter

And you have to login or it wont load the modded tags

OMG it worked lol. I wasn’t aware that you couldn’t change that. It’s all working now.

Thank you so much WareBare, been wracking my brain for 2 nights on this problem, and annoying others with it too :stuck_out_tongue:

Oh wow!
That’s a good think to know! :smiley: