Missing Characters

Two characters went missing. I recently started using Grim Internals, but didn’t have problems playing with that active, so I don’t think it’s the cause.

I have cloud saving turned on. Have never messed with that setting. There are no files or folders at the C:\Users\username\Documents\my games\Grim Dawn location.

Under Steam/userdata/…/remote/save/main, there are two folders, representing the two missing characters. Both folders start with an underscore. Under there, I have a player.gdc file, and another folder called levels_world001.map. Nothing else.

Maybe Steam cloud is temporarily down? Is there a way to check that?

Try toggling cloud off then on.

Unlikely… tho Steam does shut down portions of itself briefly every Tuesday for maintenance. Can’t say I’ve ever heard that Steam cloud gets affected by this tho.

Glad i used GOG for most of my games now.

I tried turning cloud off then back on. I also tried running the client directly, instead of via Grim Internals. Still no characters.

Try downloading the saves…

This will place anything in the cloud saves in your Documents\My Games\Grim Dawn\Saves directory.

Cloud saving would then need to be disabled for the game to access saves in this location. If the saves work properly you can then reenable cloudsaving if you like then GO BACK to the Network tab (after rebooting the game) and then DELETE cloud saves and exit the Options screen to the Menu and then the game will ask you if you want to IMPORT the local save files (in the Documents directory) back into the cloud. You would then tell it yes, whereupon it will do so.

NOTE: do not delete cloudsaves as mentioned above UNTIL you have confirmed for sure (visually checking this location) that the saves downloaded into your Documents directory properly and are working properly.

I would also note that I am pretty sure that the instructions for Grim Internals highly recommend against using the tool with cloudsaving.

Nothing came down when I did Download Saves from the Network tab. My characters were both just getting started on Elite difficulty, so rerolling isn’t a catastrophe. Just weird. I did miss the warning about cloud saving with Grim Internals, not realizing that cloud saving was on by default. Thanks for the help.

Make sure it’s off in both the Steam settings and the ingame Options menu.

This likely indicates a permissions issue with the “My Games” folder (and sub-directories) itself. Unfortunately, it is common for Windows to get stupid with permissions with this particular folder for some reason, preventing stuff from read/writing in this location properly.

You can correct this by going into the properties of My Games (then under the Security tab click Advanced)…

…and changing the owner from Administrator (which it might be set to) to your user/login name instead - this way you have full control.

The “My Games” (and on down to “Grim Dawn/saves”) was already set to me as the owner. The new character that I created shows up under the saves there, so hopefully that means cloud saving is really, really off.

Yup… if it is reading a character from the My Games location that means cloud is off. As for the other missing characters I can only guess that there might have been a sync issue/corruption due to using GrimInternals with cloudsaving active.

In the worst case GI prevents the synchronisation with the Steam Cloud and that could lead to empty inventories or stashes, not deleted characters.

As @medea_fleecestealer mentioned above, it’s important that you disable/enable Cloud Saving always in Steam AND in-game in the game options.

In your case, if Cloud Save is turned off (in Steam and ingame) try to copy the


folder to your local save folder (MyGames/Grim Dawn/ … etc.
The two missing characters should appear when you start Grim Dawn again.

Other than that I have no clue what happened

That’s what I would think too… interesting that it isn’t downloading the saves from the cloud via the button tho. Could be a sync issue borked the copies in the cloud.

As you note he should be able to move the copies in the Steam \remote location to the local saving directory to see if they are still intact.

Moving the folders from the steam remote directory to the local save directory seems to have fixed it. Anyway, the two missing characters show up again in the character list in-game. Thanks!