Mod Request - Replace Maggot with any other creatures in the game

I am aware that there is a mod available to replace spiders with boars in the game, and there is also a tutorial provided in that thread. However, my phobia of maggots daunts me and prevents me from opening the Viewer.exe to continue modding. And the first time I encountered those maggots in the game, I had to close my eyes immediately and press the power button on my PC.

Do you have a preference on what they become??

Teddy bears

1 Like

Maybe simply replace with boars. :smiley: (118.7 KB)
quick mod replaces maggots with beetles. not sure if I got them all, source is included so if anyone wants to mess with it go ahead.


Thanks a lot. :laughing:

Will this work in main campagain or only in custom game? I am only using GI for now and haven’t got time to try any mod yet.

Only custom, there’s a way to use it in the Mc but I’m not sure how do you’ll have to do some digging

1 Like

open the mod folder asylum gave
go into the database folder to the “nomaggots.arz”, change the nomaggots part to database, so it’s called database.arz
then you put that in the main root mod folder, so it looks like this

then in either your steam library options for grim dawn you set a launch command
or add that to the end of your (desktop) shortcut if you’re using that instead, or to whatever you’re using to launch GD with
(if you’re using a steam created desktop shortcut that wont work, has to be a “real” program shortcut afaik)

1 Like

I have done this but in my existing char on main campaign, I still see maggots in Temple City of Osyr (which should become Korvan Scarab by using the mod if I understand correctly “beetle”). :pensive:

works on my end

either you didn’t do the “install” proper, or you’re dealing with maggots that Asylum’s changes didn’t catch

edit. i see what you’re getting at
looks like Mummies’ maggot pets aren’t caught by the mod

yep, looks like the mummies are using a skill which summons a different kind of maggots than the entries in the mod
i can probably manage to plop those in

looks like it’s working at Osyr now too (208.8 KB)


Now it works perfectly and I finally can enjoy the game without anxiety :smiling_face_with_three_hearts:

Thanks you so much for both of you. I even didn’t expect that my problem could be solved within 2 days.