New domain feedback

There is no link to the forums on and a lot of links on there point to

I wonder if this is something that could be done in the database -> replace all entries with

Make those

scroll down to the recent threads thing down after sections.

Also, this forum is hard as fuck to navigate now. I don’t know which section is which because all I see is some dumb colors that don’t say shit. “Ideas and feedback” was always for GD only, now it’s for general purposes? “Guides and tutorials” the same, is it for general purposes? Everything is glued together and it not only looks like it’s for general purposes but also is hard as fuck to read and the text is too large which requires me to scroll 3 full times instead of the usual half or full scroll in the old forum.


just looks so weird that I never know wtf just happened. I often think I accidentally opened a section because it doesn’t say anywhere that those are the latest posts. It’s totally unreadable. I literally don’t want to use that forum anymore. It looks way better than the old one, I’ll agree on that, but the usability is so bad that I don’t even want to bother with it anymore.

Why would it be general purpose when it’s under the Grim Dawn banner? It’s exactly the same as it was on the old forum.

There’s a “totally random” section, but then again, a newcommer will see “Guides and tutorials” and will put a diablo tutorial or GTA guide, because it doesn’t clearly say it’s for GD only so they’ll think it’s okay to put it there.

You high or something? You can’t see the Guides section unless you go into Grim Dawn Forgotten Gods forum so why would anyone be posting diablo or GTA guides here? It’s exactly the same as it was on the old forum and I don’t recall seeing anyone posting such stuff there, do you? :woozy_face:

The new forums are fucked even harder than my PC.

Ok I knew something was happening with that too and thought I was maybe imagining it. @Zantai @Rhis need to watch it tho so it can be looked at and fixed.

Here's a clue for them

It appears @system - whatever @system is - is automatically deleting our quotes of others. Instantly. At least on the initial ‘quoting’ at any rate.

It removes “reply to” too. You can see on the video I clicked to reply to Maya, but it didn’t do it anyway.

Seems that Rhis saw and fixed the problem already.


Edit: or maybe not? This post replied to you @USER_NAME_01 but it’s not showing that it did. However, I’ve quoted some others in other threads since and it worked fine… so now I’m wondering if there is a bit of randomness with it? Hmm. :scorv:

I blame :zantai: for that.

Works the same as before for me.

Hey, I’m good with blaming :zantai: for pretty much everything :smile:

Edit: See?! Weirdness… that time it worked. I think when it comes to quotes it’s the randomness involved - whereas straight replies with no quotes it’s stiffing us.

To me it doesn’t work still. I worded my sentence quite weirdly before, not gonna lie. :smile:

Edit: Now works, but replying still doesn’t.

Yup. The Reply function (and indicator) is definitely borked.

I bet :zantai: banned it. :confused:


Hah… mebbe. Whatever they did with @system fucked something up with it tho. It used to show:

:in roughly that area an indicator of who you replied to but @system is killing it the moment it’s submitted.

Discourse doesn’t like it when you quote an entire post right above yours.

I’ve disabled that “feature”.

I still blame you for that. #BringPagesBack #ZantaiIsANerd #BanUserName01

1 Like

If you don’t reply until after 5 pm (my time) just know that I won’t mind :rofl::rofl::rofl::rofl::rofl:

Lol, that reason :joy:

1 Like