Obtaining backer rewards

I have my code from Humble Store for the backer rewards, but when I put the code in Steam it just tells me to click next to install but there is no next, just finish.

Has anyone else had issues redeeming for the wisp etc?

Have you talked to Kory the Keeper in Devils Crossing ?

No, cheers, worked. I was trying to look for instructions because I thought it’d be something like that.

If you’re talking about things like the Wisp, George Washington wig, etc, then yes you just need to go into the game with a toon and talk to Kory who’s near the Devil’s Crossing prison gate. He’ll give you the items as you talk to him. You can do this for all your toons to get the items for each of them. :slight_smile:

Never worked for me. I bought the loyalist edition way back before there was even a KS. I’ve followed the guide for getting them but Kory never gives them to me. I just gave up on it. I better get my free DLC though.

You contacted Humble Bumble for your key?


Got that and downloaded the update?

You did used all the keys on your humble account and entered them in steam or GoG ? (all keys should say redeemed) If it somehow didn’t worked i suggest to email Crate about it.

Anyone come across a solution for this? I didn’t even realize there were in game rewards until I went looking for my DLC key and saw that my version had them. When I speak to Kory he doesnt give any items in game.

If you just applied the key and then logged into the game and he doesn’t have them try rebooting the game. If I recall correctly that’s what I had to do my first time applying the rewards as well.

Yep, tried that, didn’t work. Do I need to reinstall the game? I’m running this through Steam BTW.

Nah you shouldn’t have to go that far. Verify the files instead or reboot Steam perhaps.

Sent from my SCH-I605 using Tapatalk

SO turns out my issue with the Crucible DLC was the same as this. Once Humble fixed my account I could see there was another code to apply to my Steam account for the backer rewards. Everything is working now :slight_smile: