PSA: Do NOT begin your first Shattered Realm run on Ultimate from above Shard 5. You may lose a Skill Point!

I need to get more sleep… This is the second post I made on this forum yesterday that was just outright incorrect. >_<

So I just recently hit 94 on my Skelemancer Cabalist, and to celebrate, a friend of mine gave me a bunch of awesome gear and helped me run through SR on Ultimate to see how well my build synergizes with her Death Knight. It turned out to work really well! We started on Shard 15, and worked our way up to successfully clearing Shard 25 with relative ease (though the final boss was a tad rough).

However, perhaps because I didn’t do the starter FG quests, I never picked up the “Entering the Shattered Realm” quest. This meant that when we cleared Shard 15, I instantly received and finished “Exploring The Shattered Realm”, which gave me 1 Skill Point. I got another Skill Point by finishing Shard 25, from “Conquering The Shattered Realm”.

Unfortunately, now that I’ve gone back and finished Act 1 and unlocked The Emissary’s quest, and then worked my way up to doing what should have unlocked Entering the Shattered Realm… the quest isn’t there. I can’t pick it up, so I can’t get the reward. And clearing from Shard 1 to 5 didn’t give me the reward, either.

So my Cabalist is sadly screwed out of one Skill Point (out of a maximum of 248). Not the end of the world, but certainly frustrating. I wanted to let everyone know not to do what I did, which is why I made this post.

If the quest cannot be brought back you can always add the missing skill point with [Tool] GD Defiler or [Tool] GD Stash.

Oh really?! Sweet! I’ll give those a look.

Back up your save folder first since you don’t have experience with these tools.
Oh and I assume you don’t use Cloud Saves because I think they should be used with local saves only.

Yeah, I have been doing backups of my save folder regularly, and I disabled Cloud saves because I’ve been using Grim Internals for a while. Thanks for the reminder, though!

:thinking: Strange, for some reason I thought it shouldn’t be the case and previous quest will get completed as well. IIRC I even tested it before.

i always do SR50 as first SR with my chars, never lost skill points

The quest function cannot even grant you the later quests until the earlier ones have been completed, nor does it check for whether you started the Forgotten Gods story.

This function also runs locally for each player, so not like any host-based MP issues could be the cause.

This seems like a freak occurrence and you should verify your game files, assuming you didn’t miscount somewhere. Which quests are complete in your quest log?

Yeah, you guys are right. It looks like I actually just counted my skill points wrong.

Is there a better way to ask the game “How many skill points do I currently have?” besides taking all your gear off and just counting points on your Masteries tabs manually?

1 Like

  • you import your character to Grim Tools

  • click Skills Window

  • number of skill points you have invested in your character
    is 248 - Points Available