[REL] Grimarillion v90d

The skills are greyed out on your item instead of normal which means they aren’t in effect. The D3 Wizard class also has a skill called chain lightning, along with the Elementalist from zenith.

I really hate all the extra classes and how much they dilute the loot pool. How can i just use Grimmest & Stash mods?

Try playing just grimmest or just stasher or combine them yourself.

That what i want to do, but how to i combine them and is the Grimmest standalone still being updated?

On version 66, I have a Problem about this new item name “plutonium nyborg”. Everytime I move or drop this item, It will auto copy itself in my inventory. Can you remove this item and make the NPC of this item stay in the city. Dont need to use “plutonium nyborg” to summon him anymore.

v66a (standalone)


Key changes:
*Grimmest tweaks.
*Bug fixes.
*Skillcap tweaks.


*Removed Quickloot for the time being as it was causing issues in MP. If you need the autopickup, use Grim Internals.
*Tweaked some stuff for Zeke/Plutonium Nyborg. Plutonium Nyborg SHOULDN’T replicate in your bags in MP, or if you place it in the stash. Plutonium Nyborg has been modified so now it is consumed on usage, and Zeke is summoned when it is consumed. Upon speaking to Zeke, you will receive a new nyborg if you don’t have one already. Plutonium Nyborg item is droppable (not sellable), but you can also craft it at the satyr if you lose it.

*Fixed an issue where several Grim Quest accessories couldn’t be crafted.

*Fixed an issue where FX weren’t working.

Spite - Blind Rage:
*Fixed an issue where the skill never made it into v66. Oops.

Distortion Field:
*Vitality retaliation changed to physical.

Plague - Fatigue:
*Max rank reduced from 12 to 10.

Plague - Susceptibility:
*Max rank reduced from 12 to 10.
*Scaling adjusted.

Kodama - Sustained Growth:
*Max rank reduced from 12 to 10.

Fungal Swarm:
*Max rank increased from 12 to 16.

Enslave Spirit:
*Reduced max ranks from 12 to 8.

Skeletal Soldier - Relentless Evil:
*Reduced max ranks from 16 to 12.

Drain Life - Grasping Dead
*Max rank increased from 8 to 12.

Drain Life - Soul Cascade
*Max rank increased from 8 to 12.

Lightning Whip:
*Fixed an issue where skill didn’t have a max rank of 16 as intended.

Not sure if this worked before or not but can’t craft D3 items with forgotten souls.

Another recurring issue, font mod no longer works with grimarillion. It will break tags on every modded classes until I revert back to the default font.

This issue occurred since v66 came along. Previous version of grimarillion works just fine with font mod.

Make sure you’re at least around level 24. I tried at 20 and couldn’t craft them, tried again at 24 and was able to. Not sure on the exact level limitation.

Hey! Ive been playing v66 and v66a version for now and my game keep crashing with unknown reason. Ive tried setting Grimmest to lowest and still crashes. Is there any method to stop the crashing? Tried to lower my video setting, doesn’t work.

Were you ever able to play the old grimmest? If you set it to off and it is crashing, then that suggest that the simple lua hook that is checking the state of grimmest is enough to cause a performance hit on some hardware. Which brings me to my next questions: what is your CPU model? Laptop or desktop?

Hello, only the ultimate shrines appear in zenith difficulty since v66, is it possible to have a quick fix on this? Thank you.

Do you plan to put in a quest like Omega in DAIL? Since there is a lot of heroes and bosses now you should put in some rewarding quest for certain number of this “star creatures” killed.
100 hell yea
1000 grim commando
10000 exterminator
100000 why not
1000000 killing is my business

I am having the same issue, no crashes at all the whole time i’ve played the game until v66.

now i crash every 10 minutes or so

Cool ty didn’t know there was a Level Limit.I am only lvl 18 :smiley: started completely new Char/chest on FG

I’ve set Grimmest to off and still crashes. This problem never happens before when I’m playing old version of Grimarillion. Also, the game version is only, does it matter?

Hi, I have a problem with aether crystals, they don’t drop. Is it only my problem?

Edit: After integrity check is it OK.

Since I installed v66 mod my game crashes for a couple time and even worse in v66a. Crashing mostly happens when a mob hits the char or char picking item, I didn’t know what’s the problem with that. Tested when Grimmest is off, still crashes. I’ve never had this problem before with those old Grimarillion version.

Did you try the main campaign?Are there any item filters external programs like grim internal that you use?I have been playing grimmest for half a day and had no problems so far.Will still test it.

Uhhh what is Zenith difficulty?..

This is always the case with Grim Dawn mods, mod features do not show in the main menu. Think of it this way - the game only knows what is in a mod when the mod is loaded. After the mod is unloaded, it forgets all that and reverts to it’s unmodded state.


I’m not sure how to fix whatever is having a conflict with this, sorry.

So far you’re the only ones to report crashing every 10 mins.

  1. Make sure you have AOM and FG installed and fully updated.

  2. Make sure you have the most recent version of Grimarillion installed, FRESH. Delete the old mod folder for grimarillion and install 66a again.

  3. Make sure you try both versions of Grim Dawn if one is crashing for you, if 64bit is crashing, try 32.

  4. If it continues to crash, try to test without playing Grimarillion, just play vanilla.

It’s impossible to bug fix a crash that one person reports if they do not give any information on what causes the crash. I don’t have crash logs, and I don’t know what to do with them if I did have them. I can only go on crashes I can reproduce on my own PC and go from there, otherwise…

Aether Clusters only drop crystals if they are a similar level as you.