[REL] Grimarillion v90d

It is, I just downloaded it.

the file from the v90 post? No, it definitely is not available…

The link in asylum’s post just above yours.

that is not the one I was talking about. He said the MEGA v90 contains the hotfix, so I wanted to download that, but the link is dead.

Ah, I see. Yes, there’s nothing there if you click on the full download link in the OP for Mega.

v90a Changelog

Fixed an issue where some MI were missing D3/Priest skill mods as intended.
Fixed an issue where Father Abaddoth and any other enemies that use player animations will have spear/staff animations again.
Ignus NPC in Conclave of the Three will no longer be glowing and offer Shattered Affix recipes.
Oxley NPC in Devil’s Crossing will now have dialog, as intended from v90.
Fixed Grimmest script to prevent it from giving you another Nyborg every session.

Diablo 3
Replaced the class title for Demo+D3 Necro (from Eradicator to Pyromaster)
Replaced the class title for Barbarian+Nightblade (from Berserker to Bladebreaker)
Fixed an issue where the low level versions of Basilisk Mark granted skillpoints to Frenzy instead of giving it to Fan of Knives.
Tweaked the D3 Boss drop system a bit more when encountered in SR. They should now drop their MI and a Forgotten Soul immediately on death (which will drop even in SR), then drop an orb which will produce one random item.

Darkest Dawn
Fixed an issue where the Illusionist mastery had the wrong art for Striat’s Vortex.

Added materia conversion recipes for the Incarnate (Zenith Crafter), you can now convert Zenithal Amalgams from Blood, Brains, Hearts, Mutagens, Missives and Wendigo Spirits.
Also added conversion recipes for the Incarnate (for now, I might move it later) to convert all the mod currencies (Forgotten Souls, Electrum Coins, and Zenithal Amalgams)
Added components to new Zenith relic recipes.
Renamed Zenithal Amalgam to Zenitham

Grim Quest:
Reworked The Furies granted skill, now triggers on attack instead of on enem death and as a result the stats were lowered.
Replaced Nemean Lion Set 3-Piece set bonus from 30% Pierce Resist for pets to 30% Bleeding Resist for pets.
Added a delay to the Rogue Lay Trap pet attack animation
Fixed an issue where Terracotta pets summoned by the Huang Di set were not invulnerable

If you’ve already installed the previous update (v90), you can skip the Full update and just use the hotfix patch at the bottom.


Hotfix only:

1 Like

Updated the Rainbow File for v90a.

1 Like

I’ve been trying to craft items for my Evoker at the Zenith Blacksmith in the personal hideout and have not been able to get lucky to craft a single item, I have received items for all other classes. Gave myself 1000
Zenithal Amalgam’s to test with, and no luck. No other mod’s used beside this one. Could i possibly be doing something incorrectly?

Really enjoying your mod BTW, so thanks for that!

I’ll have to look after work - what have you tried crafting? Important to specify which recipes you’ve been trying.

Is the G for Zeke supposed to be missing when you start a new character now? I know he’s in the hideout, but I started a new character today and didn’t get a G in the inventory bag. This was after installing the hotfix.

Implements - Zenith Lightning Implement - Does not work
Axes - Zenith One-Handed Melee Weapon - Does not work

Staves - Zenith Lightning Staff - Does not work

Armor - All tested, Does not work
One caveat, Foci - Zenith Focus, Does work

Accessories - All tested, does not work

Thanks for looking into this :slight_smile:

The left side is the original text, and the right side is your rainbow text. The question now is which one should I refer to when translating?

I updated my file from v89 to the most recent one (v90a) but now every humanoid enemy is T-posing. I tried both replacing old files with new ones and doing a fresh install of Grimarillion.

It’s my first time updating the mod so i won’t rule out that i did something wrong

Edit: It seems to affect all of the humanoids belonging to Cronley’s Gang and Chthonians, every over type of enemy seems to work normally, like the humanoids in AoM

Thanks for the report, I’m honestly surprised no one mentioned this earlier… no idea how this happened. Somehow the male animation table got scrubbed. Will post another update tonight.

Thanks, I had missed those when I compared them. Corrected.

v90b Changelog

Fixed Zantarin (and all other skeletons) missing 2h weapon animations.
Fixed an issue where all new Zenith crafted items would not generate Evoker Affixes.
Fixed an issue where 1h melee Zenith crafts required scrap metal instead of Zenitham.
Updated 1H Ranged, 2H Crossbow, 2H Melee Zenith crafts pool of base items, adding more higher level options.
Fixed an issue where male human NPC animations were completely missing. Oops…?

If you already installed v90a, you can install the hotfix. Only MEGA Links for now, will wait til tomorrow to see if we get any new catastrophic errors…


Hotfix Only:

Just checked and the npc’s are back to their normal behavior, thank you very much for the quick fix!

Edit: Hostile npc’s are back to normal but seems it also happened to some stationary guard npc’s

There are some that move and attack normally so it’s not all of them.

1 Like

v90b returns to the previous dislocation of v90.

Also, why can’t I talk to Mazaan?

Classes related to Evoker in Zenith are not displayed correctly. Perhaps some combination names are missing.
For example, Evoker (Zenith)+Wizard (D3)=(13 and 17)=Tag not found: tagSkill.
Using v89 tags_grimarillion_classnames.txt it will show “Master of Magic”.


Because there is a lack of relevant content in the corresponding text of v90a.
Moreover, there are two repeated passages in this text “Necrotic”.

Here is the text I checked:
tags_grimarillion_classnames.txt (30.9 KB)