[REL] Grimarillion v90d


my wife and I gave this mod a try in multiplayer and experienced several severe issues, essentially making the game unplayable.
The most important:

  • The joining player (the one who is not the host) seems to trigger every action he does twice. He does double damage (quad damage for ranged weapons) - even a normal hit with a white weapon on a lvl 1 character pops up two/four damage numbers. You can easily test this on the training dummies. Also some skills are casted multiple times - like summon wolves from the nature tree causing the first wolve to instantly die (death animation plays) and appear again. The wizards electrocute also does double damage (two damage numbers per hit) and consumes double the mana.
  • Sometimes summons on the joining player do not appear at all. The skill animations for summing skills play but the skill does nothing. The host does not even see the skill animation for the other player
  • The game is heavily out of sync for the joining player. Positions and animations for mobs and the host player are completely off. Often enough the monsters and the other player just stand there doing no animations. When disabling grimmest this problem disappears.

We are using GD+AOM+FG from GOG and Grimarillion v72 (also tried v71 - same problems).

Thanks for the updates!! (and so promptly)

No problem on the folder rename ish but appreciate the heads up etc.

Keep up the great work!! - this mod has reinvigorated GD for me to such a degree, it’s crazy -

P.S. Thanks to Matougi for Rainbow in general and for keeping it updated for Grimarillion!

Just installed this and it hasn’t overwritten the files, but has done this.

Only difference I can see is that the Grimarillion full has resources with 26th September while the rest are dated 12th September.

“Grimarillion_full” is a complete new copy of the mod folder.

So, delete the folder you currently have labeled “Grimarillion”.

Then, rename “grimarillion_full” to “grimarillion” (just delete the “_full” part of the folder name)

Boom, done.

Thanks lqdhorror.

There’s really nothing I can do about multiplayer desync issues. If turning off grimmest helps, then you will have to play without grimmest. jiaco tried to make grimmest as bug-free as possible for multiplayer but there’s only so much we can do as modders.

I thought so much aswell. I can live without grimmest, but the double and quad damage thing makes the game really unplayable in multiplayer.
I just tested only installing the Diablo 3 mod and the same stuff happens aswell. Will investigate some more tomorrow if the problem persists when only using the TQ masteries mod etc…

Desync happens in vanilla all the time, it’s an issue with the games netcode or something, I have no idea but this is an ooooold issue and probably just made worse with all the content from mods and their scripts.

Didn’t bother to back up my characters, but the latest version of Grimarillion has lost all the shared stash stuff again. Not a big deal for me, just for your info.

Also can’t seem to get the crate pet to spawn either with this version.

That is because the mod name is different. Renaming it back to Grimarillion should fix that.

Already did that before I started playing.

Just a quick question.Are there Legendary Staffs?or is there plans to add some in a later update?Not a biggy just curious.

Does the game still crash(screen turns black but i hear the game music), didn’t experienced with another GD mod and it goes like this on my pc: D part->Games->Grim Dawn->mods->grimmarillion :smiley:

No should be in either Steam - Steamapps - Common - Grim Dawn - mods


GOG Galaxy - Games - Grim Dawn - mods

They’ve been in the mod for over 2 years now…

1 Like

Then i just have bad luck as i never got one with my play through xD

Are the hunter’s WPS(Gouge, Serpent Strike, Volley) meant to consume mana? Not sure if the scatter shot arrows is causing this.

Steps to recreate:

  1. put skill points to Marksmanship then Scatter Shot Arrows.
  2. put skill points to WPS mentioned above.
  3. close the skill window or exit to main menu then return to character
  4. observe the wps description, it will include some mana consumption
  5. try it on a dummy, the mana consumption from wps works.

Okay, even more serious problem. Transfer stash is not saving from day to day with v72. All the items I put in there yesterday are gone, nothing left though the personal stashes are fine. Also it’s not saving anything put into it from GDStash.

I don’t think the mod does any stash handling, ie that is all done by GD itself.

When you open the stash you placed the items in with GD Stash with the tool again, are the items still there ? If so, the game uses a different stash (cloud vs local ?)

Nope, they’re not there, only the stuff I collected ingame today. And I checked whether cloud saving was on anywhere, but it’s not. I always use local saves and the cloud saving doesn’t appear in the game options so it’s off. I couldn’t see anything in GOG Galaxy for it either. Steam cloud saving is off.

I play the mod in GOG since that’s my main copy and so I don’t use the mod with any testing going on.